Web-Proxy keine SSL Verbindungen möglich

german

#1

Hallo zusammen,

ich habe heute einen weiteren UCS aufgesetzt, welcher als Transparent Proxy dienen soll.
Per UCR-Variablen habe ich folgende Einstellungen vorgenommen:

squid/transparentproxy = yes
squid/webports = 80 443 21 8080

Den Clients wurde per DHCP Option dieser Server als Gateway mitgeteilt und es funktioniert auch alles wunderbar.
HTTPS Seiten können aber leider nicht aufgerufen werden.

Im access.log von Squid gibt es dazu folgenden Eintrag:
NONE/400 4020 NONE error:invalid-request - NONE/- text/html

An welcher Schraube muss ich drehen, damit auch SSL Seiten angezeigt werden können?

Vielen Dank & Gruß
Bazinga


#2

Transparentes Proxying mit SSL ist ein ganz schlechtes Thema. Das bedeutet, technologisch betrachtet, dass Squid jede Verbindung mit einem falschen Zertifikat dem Browser gegenüber ausweisen muss, und das führt zu jeder Menge Meldungen im Browser über nicht passende/falsche Zertifikate. Es untergräbt jegliches Sicherheitsgefühl der Anwender. Ich würde dringend davon abraten und richtige Proxyeinstellungen verwenden anstelle von transparentem Proxying.

Soll transparent proxying wirklich mit SSL eingesetzt werden, so sollten Sie auch diesen Bugeintrag dazu lesen.


#3

Hallo Herr Bunkus,

vielen Dank für die Antwort. Die Begründung leuchtet ein und ich würde dann wohl doch eher auf die richtigen Proxyeinstellungen gehen.
In Sache UCS bin ich noch relativ neu. Kann ich die Proxyeinstellungen automatisch setzen bzw. verteilen? Was wäre ein guter Weg?

Gruß
Bazinga


#4

Ich habe selber bisher nichts mit automatischer Verteilung gemacht, aber genau dafür gibt es das Web Proxy Autodiscovery Protocol.


#5

Hallo Herr Bunkus,

super und vielen Dank noch einmal für die ausführliche Erklärung.
Ich werde mich in ferner Zukunft mit dem Thema mal etwas befassen und bis dahin die Einstellungen von Hand vornehmen.

Gruß
Bazinga