/var/spool/mail/username auf Dovecot Server

mail
open-xchange
dovecot

#1

Moin,

ich habe auf einem Rechner xyz.firma.de einen Dovecot mit OX am Laufen. Für einen User gibt es einen User mit

uid: userid
mailPrimaryAddress: vorname.nachname@firma.de  

Schicke ich nun an: userid@xyz.firma.de eine E-Mail wird diese unter /var/spool/mail/userid abegelgt und nicht dem User im Dovecot zugestellt.

Wie kann ich das unterbinden (entweder weiterleiten an den User oder das lokale speichern verbieten)?


#2

Die einzige Erklärung, die mir zu diesem Verhalten einfällt, wäre die Existenz eines lokalen Nutzers mit derselben UID. Bei Nutzerkonten habe ich es noch nicht geprüft, aber bei Gruppen bin ich mir aus eigener Erfahrung ziemlich sicher, dass es möglich ist, eine LDAP-Gruppe genauso wie eine lokale Gruppe zu bennenen. Das gibt auch nette Effekte.
Das beantwortet zwar nicht die eigentliche Frage, hilft aber ggf. bei der Eingrenzung und Lösung des Problems.


#3

Ja, das würde ich auch so sehen. Ist halt Standard Linux-Verhalten, dass User die auf einem System exisiteren, unter /var/spool/mail ein Postfach haben. Und unter UCS sind alle User in der LDAP auch System-User.

Ich habe versucht die local_recipient_maps zu ändern (Default: proxy:unix:passwd.byname $alias_maps) :

/etc/postfix/main.cf.local:

local_recipient_maps = $alias_maps

und dann:

ucr commit /etc/postfix/main.cf
/etc/init.d/postfix restart

leider ohne Erfolg. Die Mail wird trotzdem zugestellt.


#4

Huhu,

Postfix nimmt Mail für hostname.firma.de standardmäßig deshalb an, weil hostname.firma.de im Postfix-Parameter mydestination enthalten ist (in der Form $myhostname). Standardmäßig ist der Parameter unter Univention auf $myhostname, localhost.$mydomain, localhost eingestellt — was übrigens auch Postfix’ eigener Standard ist, wenn der Parameter gar nicht angegeben ist.

Unter Univention wird der Postfix-Parameter durch die UCR-Variable mail/postfix/mydestination gesetzt. Um den Postfix-Parameter komplett leer zu setzen, muss die UCR-Variable auf einen leeren String gesetzt werden:

[0 root@uma ~] ucr set mail/postfix/mydestination=''
Create mail/postfix/mydestination
Multifile: /etc/postfix/main.cf
[0 root@uma ~] postconf mydestination
mydestination =

Dann nimmt Postfix Mails für hostname.firma.de auch gar nicht mehr an.

Mails für die explizit in der UMC konfigurierten Domänen werden da aber durchaus weiterhin angenommen, weil die über virtual_mailbox_domains gehandlet. mydestination ist nämlich nur für User gedacht, die in der System-Benutzerdatenbank (aka /etc/passwd) vorhanden sind, wohingegen virtual_mailbox_domains für virtuelle User gedacht sind, also Useraccounts, die im System so potenziell nicht existieren sondern vielleicht nur in einer Datenbank (sie dürfen durchaus auch im System existieren, das ist aber keine Voraussetzung).

Gruß
mosu