USB-Speicher an UCS nur readonly?

german

#1

Hallo Zusammen,

ich habe hier einen Univention Server 4.1-2 errata206

Vielleicht wurde die Frage hier im Forum ja schon beantwortet und ich bin einfach nur zu dämlich zum Suchen. Finde da nicht wirklich was.

Wenn ich einen USB-Stick oder eine USB-Festplatte einstecke, sehe ich diesen dann auch im Dateimanger und kann darauf zugreifen.
Allerdings kann ich auf das USB-Speichermedium nicht schreiben. Ist mir bei zwei anderen UCS auch schon aufgefallen, da war es aber nicht notwendig, dass ich auf den US-Stick auch schreiben kann.

Wie kann ich denn den Schreibschutz für USB-Speichermedien (Stick/Festplatte) grundsätzlich abschalten?

Recht herzlichen Dank schon mal für eure Hilfe.

Gruß
Joachim


#2

Hallo,

ich kann das Problem erstmal nicht reproduzieren.

Mein Setup:
UCS 4.1-2 206 als VM in Virtualbox, KDE nachinstalliert, neu gestartet, als Administrator angemeldet. USB-Stick zur VM durchgereicht und mit Dolphin geöffnet
Ich kann ohne Probleme Dateien auf dem Stick erstellen.

# mount | grep sdb /dev/sdb1 on /media/TRANCEND type vfat (rw,nosuid,nodev,relatime,uid=2002,gid=5000,fmask=0022,dmask=0077,codepage=437,iocharset=utf8,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks)

uidNumber 2002 ist der Administrator.

Was an dem Setup (außer die Virtualisierung) ist bei Ihnen anders?

Viele Grüße,
Dirk Ahrnke


#3

Hallo,

ich hatte den Server erst ohne LVM aufgesetzt. Dachte, dass es vielleicht daran liegt.
Hab eben nochmals eine frische Installation gemacht. Geht ja schnell.

  • DVD rein
  • Installation mit manueller Netzwerkkonfig
  • Netzwerk-Adressen angegeben
  • Geführte Partitionierung
  • Gesamte Festplatte verwenden und LVM einrichten
  • etc

Direkt nach Fertigstellung der Installation, dem Neustart und der Anmeldung einen USB-Stick eingesteckt -> nicht beschreibbar
Dann eine neue 1 TB Festplatte eingesteckt -> nicht beschreibbar

Da es einen frische Installation ist, daher meine Vermutung: it’s not a bug, it’ a feature :wink:

oder mache ich bei der Installation grundsätzlich was falsch?

Ach ja, die Hardware:

Intel i3
8 GB RAM
Gigabyte H81M-HD3
Adaptec 6405E mit 2 x 2TB WD RE Platten als Raid1
DVD-Brenner

Wo find ich denn den Code-Schnipsel, den Sie gepostet haben

Grüße


#4

Hallo,

das war kein Code-Schnipsel sondern die Ausgabe des gezeigten mount-Befehls. Bei mir war der USB-Stick als /dev/sdb angekommen. Das kann bei Ihnen anders sein.

Viele Grüße,
Dirk Ahrnke


#5

Hallo Herr Arnke,
Hallo zusammen,

ich hab nun nochmals etwas recherchiert und bin selbst auf die Lösung gekommen.

Nach der Installation muss man noch

# univention-install ntfs-3g

ausführen. Dann klappt das auch mit dem USB-Stick / - Laufwerk.

Danke nochmals für die Hilfe und sorry für die Umstände.

Wäre vielleicht eine Option, die man in der Installationsroutine einbauen könnte.

Grüße
Joachim


#6

Hallo,

auf die Idee, dass der Stick mit NTFS formatiert ist, wäre ich vermutlich erst beim Lesen der Ausgabe von “mount” gekommen.
Meiner war FAT (vfat), deswegen klappte es auch ohne “ntfs-3g”.

Viele Grüße,
Dirk Ahrnke


#7

Hallo,

ich kann jetzt noch nicht mal sagen, wie die Toshiba USB-Platten aus der Schachtel raus formatiert sind, aber mit denen hat es vor dem ntfs-3g auch nicht funktioniert.

[edit] sind ntfs partitioniert
Grüße
Joachim