Upgrade / Kopano

I need to upgrade an old system but every thing I’ve tried by now failed. “Software Update” looks like this:


When I try to do package updates I get:

5 packages to be REMOVED
kopano4ucs 1.4.18

“ucr dump” shows:

kopano/repo/kopano-core: true
kopano/repo/kopano-files-releasetype: final
kopano/repo/kopano-files: true
kopano/repo/kopano-mdm-releasetype: final
kopano/repo/kopano-mdm: true
kopano/repo/kopano-smime-releasetype: final
kopano/repo/kopano-smime: true
kopano/repo/kopano-webapp-releasetype: final
kopano/repo/kopano-webapp: true
kopano/repo/kopano-webmeetings-releasetype: final
kopano/repo/kopano-webmeetings: true
kopano/repo/username: serial
kopano/repo/z-push-kopano-releasetype: final
kopano/repo/z-push-kopano: true


deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/core:/final/Univention_4.3/ /
deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/archiver:/final/Univention_4.3/ /

deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/webapp:/final/Univention_4.3/ /
deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/files:/final/Univention_4.3/ /
deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/mdm:/final/Univention_4.3/ /
deb https://serial:XXXXXXXXXXXXXXXXXXXXXXXXXXXX@download.kopano.io/supported/smime:/final/Univention_4.3/ /

I’ve tried to upgrade 4.3-2 to 4.3-3 without success.

I’ve also tried to set Kopano packages “on hold”. With this package updates fail too.

I’ve tried to install App Center packages first. This also fails.

How to fix this?

Hi @mhcsoft,

since you have a subscription I would recommend to get in touch with our support so someone can have a direct look at the system.

Until then my general recommendation would be:

  • deactivate Kopano repositories before the update
  • always install available app updates from the app center
  • only then perform the univention upgrade

Thanks for your quick reply.

Did so at 2019-11-13: KS-43952, didn’t get any feedback by now but the autoreply. This is why I’m asking here …

I’ve also tried this, didn’t help for package upgrades.

As said: This fails too!

Without package upgrades?

I think the support is a bit short at the moment because of holiday and illness, but it usually helps to send a reminder via email.

If this also happens with our repositories deactivated (and therefore maybe causing conflicts with very old packages), then I am out of an immediate idea. Additional insights could be gained from the appcenter.log.

My suggestions from above were a 1-2-3 suggestion and not try “this”, or “this” or “this”. So when app updates fail, then it also makes no sense to try the ucs upgrade (in any case both app updates and ucs upgrades also update packages first afaik).