Update zarafa to 7.2.3.657-r3


#1

Hi,
when updating zarafa to 7.2.3.657-r3 ( coming from 7.2.3.657-r2). I get an error performing the action.

The following software changes on this host will be applied: 18 packages will be installed / upgraded, 2 packages are erroneous

This operation causes problems in the following packages that cannot be resolved:

zarafa4ucs
zarafa4ucs-udm

please advice

thanks in avance


#2

Hi,

hmm, zarafa update works in my tests. Please give me the output of the following commands, maybe we get a clearer picture about what is going on

ucr set repository/online/component/zarafa_20160608='enabled' repository/online/component/zarafa_20160608/server='appcenter.software-univention.de' apt-get update apt-get -s dist-upgrade apt-get -s install zarafa4ucs-udm zarafa4ucs ucr unset repository/online/component/zarafa_20160608 repository/online/component/zarafa_20160608/server apt-get update

Best regards,
Felix


#3

Hi,

thanks for the reply.

I tried it but with the install line I get an error.

dpkg werd onderbroken; voer handmatig ‘dpkg --configure -a’ uit om het probleem te verhelpen.
dpkg was stopped; run manual dpkg --configure -a to solve the problem. ( my translation)

I did that of course.
I looks like everything went ok, only the stopping of de zarafa-server does not work ([…] Stopping Zarafa server: zarafa-serverNo /usr/sbin/zarafa-server found running; none killed.
failed!)

Is it save to remove the package and reinstall. Or do I loose all my settings? ( users/ domains etc)

Hope you know what to do

best regards


#4

Hi

hmm, very strange, please try the following (register the latest zarafa package repository, upgrade all package, reinstall zarafa-server).

-> univention-app register --component --do-it zarafa -> univention-upgrade -> apt-get --reinstall install zarafa-server

In my test setup /usr/sbin/zarafa-server and is part of the zarafa-server (7.2.3.657) software package

-> dpkg -S /usr/sbin/zarafa-server zarafa-server: /usr/sbin/zarafa-server -> dpkg -l zarafa-server ii zarafa-server 7.2.3.657 ...

best regards,
Felix


#5

Hi,

thanks for the advice.
I tried those lines. but…

it keeps getting stranger :wink: I really broke my installation I guess.

I added my screen output.
Hope you understand it.
zarafa-errors.txt (2.48 KB)


#6

Hi

could you post /var/log/univention/updater.log ?
Seems that the update broke the package status. Unless this is fixed, nothing can be installed or upgraded.

Does the “dpkg --configure -a” command help?

best regards,
Felix


#7

Hi, I addedd the log en the log.gz for completeness.
I addedd a log for dpkg --configure -a.
and a txt file with the console output.

I hope you can figure this out.

thanks again
updater.log.1.gz (50.5 KB)
updater.log (105 KB)
onconsole.txt (158 Bytes)
dpkg-conf-a.log (5.89 KB)


#8

[quote=“Aren”]Hi, I addedd the log en the log.gz for completeness.
I addedd a log for dpkg --configure -a.
and a txt file with the console output.
thanks again[/quote]

updater.log - looks ok

dpkg-conf-a.log - i can’t see an error here, does this succeed?

please also give me to output of

apt-get update apt-get -s dist-upgrade # simulate upgrade


#9

Hi,
thanks four your reply, I tried the suggested lines.
update stopped with
E: dpkg werd onderbroken; voer handmatig ‘dpkg --configure -a’ uit om het probleem te verhelpen.

and the simulated upgrade didn’t even start. I received the error right away
E: dpkg werd onderbroken; voer handmatig ‘dpkg --configure -a’ uit om het probleem te verhelpen.

running dpkg… results in : see attachment

I reboot my server every night now. If I dont’reboot daily, it will break down in two or three days…
The search for zarafa isn’t working anymore.
There are no updates in invention anymore. the previous updates did install.

Is there no way of saving the zarafa config ( users and mailbox connections) and reinstall invention?
I run my database on a other server…

thanks in advance, again :wink:
dpkg.log (5.89 KB)
update.log (5.42 KB)


#10

Hi

very strange, last line from the dpkg --configure -a output says “Starting Zarafa server: zarafa-server”.
Is the zarfa server running now? (ps aux | grep zarafa-server)
What says /var/log/zarafa/server.log?
Can you start zarafa by hand -> /etc/init.d/zarafa-server start ?

Best regards,
Felix


#11

Hi Felix,

the server is running,
I added the last logs. keep in mind that I restart the univention server every night.

I can start by hand, no problem.

wouldn’t it be much easier if I reinstall univention? I only need to export the users(settings) and there connection to the database.

thanks again
server.previous.log (38.4 KB)
server.log (814 Bytes)


#12

Hi

OK, one last attempt.

Check that the UCS LDAP server ist started (returns the LDAP object of the computer account if successful):

univention-ldapsearch cn="$(hostname)" 

Stop the zarafa server:

/etc/init.d/zarafa-server stop

Verify that the server is stopped:

/usr/bin/zarafa-stats --system # should fail with "Cannot open admin session on host localhost"
pidof zarafa-server #  should return nothing

The “dpkg --configure -a” calls the post installation script of the zarafa4ucs package. We can enable debug in this bash script by adding “set -x”.
/var/lib/dpkg/info/zarafa4ucs.postinst -> add “set -x” (without the quotes) after line 39 (after the eval “$(univention-config-registry shell)” line)

Once again, run dpkg --configure -a.

Backup/Restore:

For UCS, please have a look at wiki.univention.de/index.php?tit … nd_Restore.

For zarafa, maybe zarafa-backup/zarafa-restore (requires a license) or joontech.nl/wordpress/?p=7.


#13

Hi,

last best ??

It looks ok now.
zarafa-server did not stop when it should. So at the end I killed it and dpkg ran without errors (in my opinion, log attached)
In univention the system gave no errors anymore.
I am now updating to the last status.

It all looks good.

I still cannot stop zarafa-server with: /etc/init.d/zarafa-server stop
but that’s for now no problem.

thanks for your time and effort.