Update to UCS 3.2 not possible 'zarafa_20130228'

german

#1

Hallo,

wenn ich bei einem Kunden versuche auf 3.2 upzudaten, bekomme ich folgende Fehlermeldung:

An update to UCS 3.2 without the component ‘zarafa_20130228’ is not possible because the component ‘zarafa_20130228’ is marked as required.

Woran könnte das liegen?
In der /etc/apt/sources.list.d/20_ucs-online-component.list
stehen die Zarafa-Quellen drin.

LG,
Roland.


#2

Die Version ist zu alt, zuerst muß zarafa daher auf eine Version angehoben werden, die es auch für 3.2 gibt. Dies geht über das AppCenter.


#3

Zarafa ist auf dem Server gar nicht installiert - nur die Schema-Erweiterung für LDAP.


#4

Ist Zarafa überhaupt nicht installiert oder nur nicht auf diesem Server? Wenn es auf einem anderen Server installiert ist, sollte dort das Upgrade von zarafa erfolgen. Bei dem aktuellen Server handelt es sich um den Master?


#5

Nein, nur nicht auf diesem Server.
Der Server auf dem der Fehler auftritt ist der DC Master.

Das Problem ist, dass ich den Zarafa-Server hier in meiner virtuellen Testumgebung nicht verfügbar habe.
Ich wollte das UCS-Update und anschließend ein Samba 3 -> 4 zuerst einmal durchspielen, bevor ich es am Produktiv-System mache. (dort sind die Wartungsfenster sehr kurz)


#6

Hm ich würde erstmal den zarafa aktualisieren. Aber du kannst folgendes auch mal auf dem Test-Master probieren:

univention-add-app -m -l zarafa

Aber ich kann nicht garantieren, daß es funktioniert.


#7

Die Meldung lautet dann, nachdem er die Quellen durchgeht:

App “Zarafa Collaboration Platform” may not be installed.

Ausprobieren kann ich auf dem System alles. Ich kann es jederzeit wieder zurücksetzen. :slight_smile:
Danke für die vielen Tipps. Ich hoffe ich schaffe das noch irgendwie vor nächste Woche Mittwoch.


#8

Ich würde ja erstmal zarafa update, aber wenn das erstmal außen vor bleiben soll, dann könntest du auch versuchen das zarafa-Repository zu deaktivieren über die UMC (oder mit ucr).


#9

Das hat schonmal geklappt.
Habe das zarafa-ucs-schema deinstalliert und das zarafa-Repository deaktiviert.

So konnte ich ohne Probleme alle Updates bis 3.2-4 einspielen.

Jetzt würde ich gerne das zarafa-schema wieder installieren.
Nur das alte Repository (zarafa4ucs.linet-services.de) gibt es nicht mehr. Wo finde ich das jetzt?


#10

appcenter.software-univention.de … component/