Update error... best method to resolve?


#1

I am running 3.0.2
This system has 8 errata updates to perform and I receive the error(s) shown below. How is the best way to resolve this?


Reading state information…
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up postgresql-common (113.17.201111140757) …
Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2012-09-17 07:59:41 MDT LOG: could not open configuration file “/etc/postgresql/8.4/main/pg_hba.conf”: No such file or directory 2012-09-17 07:59:41 MDT FATAL: could not load pg_hba.conf … failed!
failed!
invoke-rc.d: initscript postgresql, action “start” failed.
dpkg: error processing postgresql-common (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql-8.4:


#2

Hello,

please attach the output of the following commands to your next answer:

dpkg -l \*postgres* | grep ^ii
dpkg -C

Kind regards,
Tim Petersen


#3

I ran the commands on the server in question (ucs3-dc4). See image below for results. It looks like there is a configuration error.


The server ucs3-dc3 seems to be working ok, and I get the following (see image)



#4

Hello,

you could try to reconfigure the postgres package. If this doesn’t work, my advice would be to reinstall postgres again.
Here are the commands:

# reconfiguring
dpkg --configure postgresql-common
# if this doesn't work, try to reinstall
apt-get install --reinstall postgresql-common

Kind regards,
Tim Petersen


#5

Neither appeared to work out. Reconfigure:


Reinstall:



#6

Hello,

okay, then please try to remove the packages and do a fresh install afterwards:

apt-get purge postgresql-8.4 postgresql-common apt-get install postgresql-8.4 postgresql-common

Kind regards,
Tim Petersen


#7

That worked perfectly. Thanks!