Unable to get ucs to connect to storage server free nas


#1

hello anyone
have been working on this some time but unable to accomplish the task

installed ucs did updates seems to be ok.
created linux computer in member server container.
attempted to copy certs but they are not in folder etc/uninvention/ssl

I know I saw the certs before attempting to copy them. reinstall unc and try again
can any one please instruct me on once the OS. is installed what needs to be done or refer me to documentation on this subject.
please help
thanks
rich45


#2

Hi @rich45,

I saw this post of yours Repair system critical error but I guess this is solved? Did you install the App Active Directory-compatible Domain Controller and all join scripts are executed? Did you install UCS with the master-role? If you can answer these questions with ‘yes’ and only if you can answer them with ‘yes’ then consider moving forward to the next step:

Why? Freenas is not linux and creating it in the “member server container” will not help. I discussed the roles with you here: Not able to communicate with smb shares from freenas. Point no.5.
“Will not help” means the following: if you chose the role ‘member-server’ you can - after a successful join of freenas - manage shares (that are already created on freenas) over UCS/UMC (domain - shares). So that you are able to assign them as user-directories and so on. If you create a ‘linux computer’ and put it in LDAP ‘member server’ container you can’t.
If you only want to connect to freenas-shares with the user-credentials managed through UCS, then you can leave this consideration aside. I have never tried the ‘linux role’ for freenas but even this should do as long as you don’t run into this:

They should be there, they must be there, they have to be there! (don’t forget the leading / which will make it /etc/univention/ssl/) And as long as you don’t have the right certificates on UCS that you can import to freenas a join from freenas will fail! So there is no need to proceed with any freenas configuration (which is described in several threads here in the forum).

Best, Bernd


#3

hello lebernd

the problem is not solved I am looking at this error right now and have no idea how to resolve it I have reinstalled the OS several times due to this help please. not able to log in with any user credentials including administrator
in regards to your earlier statement I have installed the domain controller software during initial install. when looking at join scripts they all say successful so i think yes is the answer
what do you think is the issue? this issue appeared after creating a user with domain admin credentials
root logins are not permitted
thanks rich45


#4

Hello @rich45

I’m sorry to hear that you have so much trouble in setting up UCS. My advise is to carefully install UCS once again.
What do you use as hardware? Do you use the iso-image or a virtual machine?
This sounds good:

But not being able to log-in (website) as administrator and not being able to ssh as root to UCS, that definitely sounds bad.
If you don’t want to install UCS again I think you should open a thread regarding these errors on UCS leaving aside all the freenas stuff.

Best,
Bernd


#5

thanks for responding
I am using intel processor quad4, 6 gig ram
the amd64 version from ucs site. not sure if amd is related to processor type or not. when I look at the statistics the machine is not working hard. I know 8G is recommended but the sytem does not seem to have issue. plan to switch to new server that is specialized to run vms. but for now to get experience please help me to fix this thank you

rich45


#6

This should definitely work (if you don’t plan to have many users attached to it, but for the installation process this should be fine)

It is (not) - it is related to the 64bit architecture first developed by amd but since then also implemented on all intel processors.

If I read the state your installation is in at the moment correctly then I don’t have a clue what to do as you can’t log-in to UCS in any way. Did you check your passwords? Single characters have a huge impact there (too).


#7

thanks
not many users myself and one other one vm transferred to WISE device. 2 windows machine as part of the domain. what do you think about the install not install controller software and do that after it is installed. also downloading iso 4.0. burn that to cd and try again
the iso says amd64 4.0 this is the updated version?

rich45


#8

No, I would not do that.
The latest version is 4.4 and you should at least have 4.3


#9

looking at the site this is the only iso available.


#10

Which site? univention.com is showing only 4.4
https://www.univention.com/downloads/download-ucs/


#11

yes that is correct the reason I was questioning as the system showed it was the same file. would you recommend the radius server on initial install?


#12

Not if you don‘t need it right away, but it should not matter


#13

the programs I am going to install is the domain, kvm, virtual management soft ware

still would like to know what causes this critical error.

if you have any other suggestions to the install would appreciate it.

rich45


#14

I would perhaps not install these considering your hardware specs. Any VM will need RAM.

And: If you can, don’t use your-domain.local as domainname as it will interfere with mdns-services (bonjour) running on the network.
If you own a public domain like your-domain.tdl then better use something like intern.your-domain.tdl (something that is definitely NOT resolvable from public DNS). If not, perhaps I would try something like your-domain.intranet