UCS joining an existing Windows Domain not working

I am trying to get my new UCS to join my Windows Domain. I am getting all sorts of odd issues.

#1 can not join the domain. Times out after about 30 secongs, % complete sits at zero the entire time.

#2 When I first click on “Domain Join” The authentification dialog comes up:
Administrator : Username
{blank| : Password
dc2.dbwsys.mb.ca : Hostname or domain controller master

Here is the issue. dc2 does not exist any more. I have tried to clear it out of the AD in Windows, thought I had gotten everything. Obviously something missing. The actual master is dbwsys1.
Any idea how to fix this issue?

Does this help?

Thank you that worked, got farther than I did before. Now it is stopping with this error:
The system join process could not be completed:

The ssh-login to Administrator@dbwsys1.dbwsys.mb.ca failed with "ssh: connect to host dbwsys1.dbwsys.mb.ca port 22: Network is unreachable ". Please make sure the account Administrator exists and is a member of the Domain Admins group!

More details can be found in the log file /var/log/univention/join.log.
Please retry after resolving any conflicting issues.

Can you post your join.log and describe which server has which role and which name?

I cleaned up the issues with the DNS server, and then tried a fresh install of the Univention server from scratch. That seemed to work fine.