UCS 5.x using php 7.3

I see that Apache on UCS 5.0-2 errata382 uses php 7.0

php 7.3 is already installed and php -v displays PHP 7.3.31-1~deb10u1

Can I switch Apache to using php 7.3 somehow (without breaking UCS) or are there plans to switch to 7.3 in one of the next updates? I have a custom app running on that server and a security update would require php >= 7.2.

Thank you boospy.

In case anyone else is searching for this:

apt remove php7.0*

caused the following to uninstall from my system:

libapache2-mod-php7.0 php7.0 php7.0-bz2 php7.0-cli php7.0-common php7.0-gd php7.0-json php7.0-ldap php7.0-mbstring php7.0-opcache php7.0-readline php7.0-xml php7.0-zip

Cross-checking the installed 7.3 packages, I found that one was missing! So I installed:

apt install php7.3-ldap

Then I had to enable the php7.3 mod:

a2enmod php7.3

1 Like

Today, php was not loaded correctly, so I reran

sudo a2enmod php7.3
the system says:
Considering dependency mpm_prefork for php7.3:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.3:
Module php7.3 already enabled

and now php is working again