UCS 5/ox-connector issue: OX global addressbook: all telephone numbers with leading "b'[number]'"

Hello all,

as I created a dav.domain.tld for OX addressbook/CardDAV sync to mobile clients I recognized in the mobile phone addressbooks that all telephone number entries in global addressbook have a leading “b” and single quoted numbers. E.g.: If the telephone number of an OX user is “+49-9876-54321” then the entry in the global addressbook is “b’+49-9876-54321’”. All users/entries have this issue, so I assume this problem exists from beginning. The CardDAV is not the problem, because also in the OX global addressbook all entries are wrong.

It seems to be a problem with the synchronization between LDAP => OX. The telephone number entries in LDAP are correct. Also a user change with modified number has the same result. Same with additional telephone/cell phone numbers.

Any ideas?

1 Like

Did you solve the problem? Because I have this too and I haven’t found a solution.

Hi @groupion-it ,

no this is still not fixed by Univention. I`m not sure if they saw this already?

What I have done as workaround:
Read the LDAP phone entry for each user and modify the entry in OX database with /opt/open-xchange/sbin/changeuser with the --telephone_business1 option.

Please check follwing topic: OX Appsuite 7.10-6-ucs4 installation/upgrade - #2 by getcom
Here I found something similar in the log files which could be a hint for the developers.