UCS 2.4-4.7 Your apache2 configuration is broken

german

#1

Bei einem “kleinen” Update auf einem Testsystem war mir eine Fehlermeldung bzgl. einer angeblich fehlerhaften Apachekonfiguration aufgefallen (vgl. unten markiert mit “<<<<<<<<<”). Da das System aber problemlos neu startete, die Web-GUI problemlos bedienbar war und der Konfigurationsdateiencheck zumindest keine Fehler bringt frage ich, ob man den Fehler ignorieren darf.

apache2ctl configtest

Syntax OK

Starting dist-upgrade at Thu Mar  8 19:42:41 CET 2012
Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be upgraded:
  firefox libapache2-mod-php5 libpng12-0 php5 php5-common php5-gd
6 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.6MB of archives.
After this operation, 4096B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  firefox libpng12-0 php5-gd libapache2-mod-php5 php5-common php5
Authentication warning overridden.
Get:1 http://apt.univention.de hotfixes/amd64/ firefox 3.6.27-1 [14.4MB]
Get:2 http://apt.univention.de hotfixes/amd64/ libpng12-0 1.2.27-2.25.201202201807 [168kB]
Get:3 http://apt.univention.de hotfixes/amd64/ php5-gd 5.2.6.dfsg.1-1.174.201203011406 [37.0kB]
Get:4 http://apt.univention.de hotfixes/amd64/ libapache2-mod-php5 5.2.6.dfsg.1-1.174.201203011406 [2620kB]
Get:5 http://apt.univention.de hotfixes/amd64/ php5-common 5.2.6.dfsg.1-1.174.201203011406 [368kB]
Get:6 http://apt.univention.de hotfixes/all/ php5 5.2.6.dfsg.1-1.174.201203011406 [1086B]
Fetched 17.6MB in 15s (1141kB/s)
(Reading database ... 115560 files and directories currently installed.)
Preparing to replace firefox 3.6.26-1 (using .../firefox_3.6.27-1_amd64.deb) ...
Unpacking replacement firefox ...
Preparing to replace libpng12-0 1.2.27-2.20.201107201344 (using .../libpng12-0_1.2.27-2.25.201202201807_amd64.deb) ...
Unpacking replacement libpng12-0 ...
Preparing to replace php5-gd 5.2.6.dfsg.1-1.167.201106141653 (using .../php5-gd_5.2.6.dfsg.1-1.174.201203011406_amd64.deb) ...
Unpacking replacement php5-gd ...
Preparing to replace libapache2-mod-php5 5.2.6.dfsg.1-1.167.201106141653 (using .../libapache2-mod-php5_5.2.6.dfsg.1-1.174.201203011406_amd64.deb) ...
Unpacking replacement libapache2-mod-php5 ...
Preparing to replace php5-common 5.2.6.dfsg.1-1.167.201106141653 (using .../php5-common_5.2.6.dfsg.1-1.174.201203011406_amd64.deb) ...
Unpacking replacement php5-common ...
Preparing to replace php5 5.2.6.dfsg.1-1.167.201106141653 (using .../php5_5.2.6.dfsg.1-1.174.201203011406_all.deb) ...
Unpacking replacement php5 ...
Processing triggers for menu ...
Setting up firefox (3.6.27-1) ...
Setting up libpng12-0 (1.2.27-2.25.201202201807) ...
Setting up php5-common (5.2.6.dfsg.1-1.174.201203011406) ...
Setting up libapache2-mod-php5 (5.2.6.dfsg.1-1.174.201203011406) ...
Your apache2 configuration is broken, so we're not restarting it for you.   <<<<<<<<<
Setting up php5-gd (5.2.6.dfsg.1-1.174.201203011406) ...
Setting up php5 (5.2.6.dfsg.1-1.174.201203011406) ...
Processing triggers for menu ...
...

#2

Hallo,

da der anschließende configtest erfolgreich abgeschlossen wird und Apache startet, würde ich vermuten, dass die Meldung aufgrund einer temporären Inkonsistenz während des Updates der PHP-Pakete generiert wird und daher vernachlässigt werden kann.

Mit freundlichen Grüßen
Janis Meybohm