System findet keine Updates mehr?!?

german

#1

Hallo,

ich kann schon seit einiger Zeit nicht mehr updaten da das System keine Updates findet:

[code]root@srv-dc:~# univention-upgrade

Starting univention-upgrade. Current UCS version is 4.1-1 errata128

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none
Checking for app updates: none[/code]

Habe schon alles neu gestartet, ohne Erfolg. Firewall-Log zeigt auch nichts Auffälliges an. Jemand eine Idee worans liegt?


#2

Hallo,

Sie könnten mal in /etc/apt/sources.list.d/15_ucs-online-version.list nachsehen, ob dort die Repos auf updates.software-univention.de drinstehen.

Viele Grüße,
Dirk Ahrnke


#3

Da sind folgende Einträge vorhanden:

deb https://updates.software-univention.de/4.0/maintained/ 4.0-0/all/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-0/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-0/all/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-0/amd64/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-1/all/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-1/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-1/all/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-1/amd64/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-2/all/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-2/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-2/all/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-2/amd64/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-3/all/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-3/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-3/all/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-3/amd64/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-4/all/ deb https://updates.software-univention.de/4.0/maintained/ 4.0-4/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-4/all/ deb https://updates.software-univention.de/4.0/unmaintained/ 4.0-4/amd64/ deb https://updates.software-univention.de/4.1/maintained/ 4.1-0/all/ deb https://updates.software-univention.de/4.1/maintained/ 4.1-0/amd64/ deb https://updates.software-univention.de/4.1/unmaintained/ 4.1-0/all/ deb https://updates.software-univention.de/4.1/unmaintained/ 4.1-0/amd64/ deb https://updates.software-univention.de/4.1/maintained/ 4.1-1/all/ deb https://updates.software-univention.de/4.1/maintained/ 4.1-1/amd64/ deb https://updates.software-univention.de/4.1/unmaintained/ 4.1-1/all/ deb https://updates.software-univention.de/4.1/unmaintained/ 4.1-1/amd64/

Denke da fehlt nichts oder?


#4

Ich sehe gerade, dass die Errata-Repos in 20_ucs-online-component.list stehen.
Und das auch nur wenn repository/online/component/4.1-1-errata=“enabled” ist. Bzw. entsprechend der eingesetzten Version.


#5

Die sieht so aus:

deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ ucc_20150807/all/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ ucc_20150807/amd64/ deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ ucc_20150807/all/ deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ ucc_20150807/amd64/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ zarafa_20160222/all/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ zarafa_20160222/amd64/ deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-1-errata/all/ deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-1-errata/amd64/ deb https://updates.software-univention.de/4.1/unmaintained/component/ 4.1-1-errata/all/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ zarafa-webapp_20160222/all/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ zarafa-webapp_20160222/amd64/ deb https://updates.software-univention.de/4.0/maintained/component/ 4.0-4-errata/all/ deb https://updates.software-univention.de/4.0/maintained/component/ 4.0-4-errata/amd64/ deb https://updates.software-univention.de/4.0/unmaintained/component/ 4.0-4-errata/all/ deb https://updates.software-univention.de/4.0/unmaintained/component/ 4.0-4-errata/amd64/ deb https://updates.software-univention.de/3.2/maintained/component/ 3.2-6-errata/all/ deb https://updates.software-univention.de/3.2/maintained/component/ 3.2-6-errata/amd64/ deb https://updates.software-univention.de/3.2/unmaintained/component/ 3.2-6-errata/all/ deb https://updates.software-univention.de/3.2/unmaintained/component/ 3.2-6-errata/amd64/ deb http://appcenter.software-univention.de/univention-repository/4.1/maintained/component/ z-push_20160203/all/ deb http://appcenter.software-univention.de/univention-repository/4.0/maintained/component/ z-push_20160203/all/

Sollte also auch passen. Kann ich das von der Konsole aus auch abfragen, ob die Errata Updates enabled sind?


#6

[code]root@m:/etc/apt/sources.list.d# ucr search repository/online/component/4.1-1-errata
repository/online/component/.*:
In addition to the standard repository additional components can be included. While such components are usually included through the Univention App Center, they can also be configured manually in Univention Configuration Registry. To include a component the option ‘repository/online/component/COMPONENTNAME’ must be activated. Additional parameters can be set following the scheme ‘repository/online/component/COMPONENTNAME/OPTION=VALUE’.

repository/online/component/4.1-1-errata/description: Errata updates for UCS 4.1-1
The description of a repository component.

repository/online/component/4.1-1-errata/version: 4.1
Components can be versioned. This ensures that only components are installed that are compatible with a UCS version. If the variable is empty or unset, all versions of the same major number will be used. If for example UCS 3.2 is installed, all repositories of the component with version numbers 3.0, 3.1 and 3.2 will be used if available. If the variable is set to ‘current’ all versions of the same major version will be included. Additionally it will block all minor and major upgrades of the installed UCS system until the respective component is also available for the new release. Patch level and errata updates are not affected.

repository/online/component/4.1-1-errata: enabled
In addition to the standard repository additional components can be included. While such components are usually included through the Univention App Center, they can also be configured manually in Univention Configuration Registry. To include a component the option ‘repository/online/component/COMPONENTNAME’ must be activated. Additional parameters can be set following the scheme ‘repository/online/component/COMPONENTNAME/OPTION=VALUE’.

root@m:/etc/apt/sources.list.d# grep 4.1-1 20_ucs-online-component.list
deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-1-errata/all/
deb https://updates.software-univention.de/4.1/maintained/component/ 4.1-1-errata/amd64/
[/code]

Ich würde dann auch mal versuchen, ob z.B. curl oder wget updates.software-univention.de/ … -1-errata/ können.
Und /var/log/univention/updater.log anschauen.


#7

Das schaut bei mir genauso aus! Ein wget haut auch hin, also die Verbindung klappt. Die Einträge im log sehen so aus (grad nochmal aktuell probiert):

[code]Starting univention-upgrade. Current UCS version is 4.1-1 errata128

Checking for local repository: none
Checking for release updates: none
Checking for package updates: none
Checking for app updates: Calling upgrade-search
0
Calling update
0
UCS Version is ‘4.1’
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz”…
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz.gpg”…
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/categories.ini”…
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/rating.ini”…
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/license_types.ini”…
… Not Modified
0 file(s) are new
100
Loaded 129 apps from cache
Checking cups=1.5.3
Checking dhcp-server=10.0.1
Checking fetchmail=6.3.21
Checking samba4=4.3
Checking ucc=2.1r1
Checking z-push=2.2.8
Checking zarafa=7.2.1-51838
Checking zarafa-webapp=2.1.2
100
none
Calling upgrade-search
Calling upgrade-search
0
0
Calling update
Calling update
0
0
UCS Version is ‘4.1’
UCS Version is ‘4.1’
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz”…
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz”…
… Not Modified
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz.gpg”…
Downloading “https://appcenter.software-univention.de/meta-inf/4.1/index.json.gz.gpg”…
… Not Modified
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/categories.ini”…
Downloading “https://appcenter.software-univention.de/meta-inf/categories.ini”…
… Not Modified
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/rating.ini”…
Downloading “https://appcenter.software-univention.de/meta-inf/rating.ini”…
… Not Modified
… Not Modified
Downloading “https://appcenter.software-univention.de/meta-inf/license_types.ini”…
Downloading “https://appcenter.software-univention.de/meta-inf/license_types.ini”…
… Not Modified
… Not Modified
0 file(s) are new
0 file(s) are new
100
100
Checking cups=1.5.3
Checking cups=1.5.3
Checking dhcp-server=10.0.1
Checking dhcp-server=10.0.1
Checking fetchmail=6.3.21
Checking fetchmail=6.3.21
Checking samba4=4.3
Checking samba4=4.3
Checking ucc=2.1r1
Checking ucc=2.1r1
Checking z-push=2.2.8
Checking z-push=2.2.8
Checking zarafa=7.2.1-51838
Checking zarafa=7.2.1-51838
Checking zarafa-webapp=2.1.2
Checking zarafa-webapp=2.1.2
100
100[/code]


#8

Irgendwie gehts bei mir heute etwas schleppend.
Es gibt noch eine /var/log/univention/errata-updates.log…


#9

Die Datei gibt es zwar, ist aber leer. Tja, und nu?


#10

Hallo

ich schreibe mal dazu, da bei mir Updates auch in dieser Weise nicht angezeigt werden.
Errata 137 war das letzte auf DC und DC-Backup.

errata-updates.log ist leer.

Mein DC-Slave Server findet neue Updates. Es ist mir schon letzte Woche aufgefallen, da war der Slave bei Errata 140 und die beiden anderen bei 137.

Viele Grüße,
Bernd


#11

Bin jetzt am System und hab mal in der Admin Oberfläche gekuckt. Sollte da nicht mehr drin stehen (siehe Anhang)?



#12

Bei meinen Systemen steht auch nicht mehr.


#13

Ich habe gerade in den angegebenen Dateien nachgeschaut und jeweils DC (keine Updates vorhanden) und DC-Slave (Updates vorhanden) verglichen. Ich sehe keine Unterschiede d.h. keine, die nicht mit dem Status oder dem Zeitpunkt der Installation zu tun hätten.

Die Registry sieht gleich aus (im DC sind mehr Einträge vorheriger Versionen)…
Unterschied in der Registry (wobei ich denke, dass es eben die unterschiedlichen Apps auf DC und DC Slave betrifft):
DC: repository/app_center/installed CU-DH-FM-KD-MA-NA-PK-PI-PS-S4-ME-XR
DC-Slave: repository/app_center/installed OQ-PK-PA

Das Console-Bild sieht bei mir genauso aus, auf beiden Systemen.

???


#14

Ich habe etwas gefunden:

und zwar habe ich, leider schlecht dokumentiert - also weiß ich den Grund nicht mehr - einen Eintrag in:

/etc/apt/sources.list

gemacht, ich brauchte wohl ein Debian-Paket. Dieses auskommentiert geht das Upgrade wieder bei mir.

Vielleicht hilft es bei der Suche?


#15

Da steht bei mir nix drin, hab ich als erstes kontrolliert.

Tja, bei mir gehen nach wie vor keine Updates mehr. Gibts auch ne Möglichkeit manuell die Pakete zu laden und zu installieren?


#16

“univention-upgrade” ist effektiv ein Wrapper für die apt-Tools. Man könnte mal schauen, ob man beim Aufruf von “apt-get update” Hinweise findet, warum aus dem Errata-Repo nicht mehr aktualisiert wird.


#17

Hallo,

vielen Dank für Ihre Bemühungen, ich denke das war der entscheidende Hinweis! Ich bekam eine Meldung und musste ein “dpkg-configure -a” ausführen. Daraufhin wurde einiges gemacht. Habe dann univention-upgrade ausgeführt und schon wurden Aktualisierungen gefunden!! Momentan läuft gerade das upgrade!


#18

Alles klar, das upgrade ist durch! Der Server ist jetzt auf dem aktuelle Pachlevel.

Vielen Dank nochmal!