[SOLVED] DNS forward to subdomain on external server

dns

#1

Hi,

I am using an UCS 4.3 server and have the DNS server activated. The FQDN of this server is in the style subdomain.domain.tld. One of our services is hosted external. Now I have the problem, that clients which are using the UCS server as DNS can not find the external server by the host name in the style subdomain2.domain.tld.

Now I created a host record in the DNS zone domain.tld with the name “subdomain2.domain.tld” and the IP-Adress of this external server as value. But the clients still can not reach this server.

What do I have to do that the clients can reach this server?

Andy


Add a DNS A record
#2

Moin,

do they fail to resolve ‘subdomain2.domain.tld’ or do they fail to reach the resulting address?


#3

They fail to resolve.


#4

Moin,

please check the output of

univention-ldapsearch relativeDomainName=subdomain2


#5

The output is:

# extended LDIF
#
# LDAPv3
# base <dc=domain,dc=tld> (default) with scope subtree
# filter: relativeDomainName=subdomain2
# requesting: ALL
#

# search result
search: 3
result: 0 Success

# numResponses: 1

I replaced the original domain names with domain, tld and subdomain2 in this posting.


#6

So the entry for subdomain2 never made it to the LDAP. If you check in the UMC, you should not find the entry there, too. Try creating it again.


#7

So, maybe I did it completely wrong . . .

Maybe you could help me with the steps? This is how I did it:

  1. opened DNS-Settings under Domain
  2. Selected the zone domain.tld on the left side
  3. Added a host record for subdomain2.domain.tld with the external IP address as value

Cheers!

Andy


#8

If you really entered subdomain2.domain.tld in the ‘Hostname’ field, you actually created an A record for ‘subdomain2.domain.tld.domain.tld’.


#9

Hi,

I’m resolving such need with creating a DNS Zone on the UCS DNS Server

Zone name = FQDN of external server and ip = ip address of the external server - this works for me on different installations since years - do not know if there is a better way

rg
Christian


#10

@bytemine: Good to know … I only did this because there was already a record like this for the univention server.


#11

@externa1: Thx, it’s working like a charm.