Slapd cannot run after upgrade

openldap

#1
59646b85 over;loading translog overlay 59646b85 over:db_init 59646b85 OVER:configuring translog verlay ......
bdb1538  program version 5.3 doesnot match environment version 5.1 59646b85
bdb_db_open :database "dc=kan,dc=edu;dc=af" cannot be opened ,error -30969.restore from backup! slap_s startup failed

#2

Hello @mamoon,

That are some sparse information. Can you provide some more details? What UCS Version are you currently running? (e.g. run univention-app info and paste the output here). From which version to which version did you upgrade?
Are some packages in an unconfigured state (run dpkg --audit)?

This line here:

bdb1538  program version 5.3 doesnot match environment version 5.1 59646b85

indicates this at least.


#3

Sorry for the late response
UCS version is 4.1 -4 errata 439


#4

yes their are some packages in unconfigured state like
apache2-mpm-prefork
apache2.2-bin
apache2.2-common
libapache2-mod-perl2
libapache2-mod-php5
libapache2-reload-perl
php5-curl
php5-gmp
php5-mcrypt

i tried every thing got nothing
slap was also in that list but i solved that issue


#5

In case this issue still exists:
It is nearly impossible to provide qualified advise without more context.
During slapd upgrades the system creates a backup of the LDAP-database, upgrades the package and then imports from the backup. If this process is interrupted one might end in a situation where the interrupting source has to be indentified and fixed. The fixing method will be relevant for any further advise.