Rocket.Chat Push

rocketchat

#21

I, too, am working through configuration issues with Rocket.Chat. I really like the LDAP integration with UCS, etc. I am immensely frustrated with the mobile notification / push problems. It simply does not work as installed from UCS.

Web client to web client seems good. Web client to mobile rocket.chat or mobile to mobile works as a chat app fine, just as long as the user is online and active. Otherwise, no notifications and the user drops offline.

Frustrating.

On other systems, I have been using XMPP client xabber app logged into XMPP servers Prosody and Openfire. Notification to the mobile android app are stable and work well. I was hoping to use the preconfigured rocket.chat as a complete solution, but, the lack of mobile notification is a real problem.


#22

Nice that I’m not the only one … Now only patch from UCS or Rocketchat is still missing.


#23

Hello @jsatterfield,
Hello @blue67,

Rocket.Chat itself offers push notifications as feature. It seems to be a configuration or networking issue that could not yet be hunted down to the cause.

The plans are to provide an update for the upcoming Rocket.Chat 1.0 release and then have a closer look at it. Would it be possible that one of you can make himself available for a screen sharing debugging session? This would be very helpful.

Best regards,
Nico


#24

btw. just did a quick check on one of my test systems, since I was testing app updates anyways (and already have the rocket chat app installed from another test) and for me the push notifications now seem to work out of the box. even without the setup wizard.


#25

I would be happy to assist. Just let me know the details of how.

John


#26

@fbartels I have a couple of questions!

  1. do the notifications you are reporting as successful include notification / push to a mobile client such as the native Rocket.Chat android app?

  2. was your install a straight forward install from the UCS application pool? I have tried removing/reinstalling and even a fresh UCS install and then add Rocket.Chat with identical recuring notification problems.

I would be happy to start from scratch and follow detailed UCS recommended procedures in an attempt to resolve this!

John


#27

Yes indeed, tested with the normal Android app (so not the experimental React Native app)

Yes, indeed. To makes sure no leftovers where there I removed the rocketchat dir from the appcenter directory, then installed the app from the (testing-)appcenter. After changing the admin password I enabled rocket chat for one of my ldap users and logged in with this user on the app. When sending a message to the user from admin I then got the notification.


#28

Thank you, that is encouraging. I will try the same steps.


#29

After a new installation push works now. At least from user to user, but not from live chat to live chat agent, which would be important … It probably was due to an unsuccessful registration of the token with the Rocketchat server. Maybe even then the Rocketchat server was temporarily unavailable. However, there is also a double-slash error in the “Rocket.Chat Register Workspace” registration email:

https://mydomain.de/rocketchat//admin/cloud/?token=xxxxxxx-xxxxx-xxxx-xxxxx-xxxxxxxxxxxx

Six hours ago, the 1.0 Final Version was released. Maybe soon available in UCS? In any case, the 0.7x versions of Rocketchat are not yet usable in a productive environment. Too many inconsistencies.


#30

Hello @blue67,

the works on the Rocket.Chat 1.0 app update will start next week. It hopefully will be finished within two weeks including the major effort part on testing. For the update it is also planned to bring back the Rocket.Chat system wizard. Maybe this helps resolving the push notification issue.

Best regards,
Nico


#31

Hello gulden, that’s good news. Are there any steps to completely remove Rocketchat 0.7x from UCS, including the previous configuration. In preparation for version 1.0?


#32

Hello @blue67,

the upgrade to 1.x is intended to not remove any data.

The Rocket.Chat data is persistent on the UCS host at /var/lib/univention-appcenter/apps/rocketchat/data. If you want to remove old data, you need to uninstall the app and then remove the content of that data directory.

Best regards,
Nico


#33

Oh this tip is very importan for me. He triggers e.g. also the problem with the broken LDAP connection, as I had seen. It would also be nice to have a checkbox in UCS for removing this folder. Then I’m looking forward to version 1.0 in about two weeks. There were quite a few bugs from RC removed. Many thanks for the help.