Regelmäßige Fehlermeldung: Authentifizierung bei IMAP-Anfrag

german

#1

Ich bekomme seit einiger Zeit die regelmäßige Fehlermeldung im Logfile:

Dec 11 09:05:02 server cyrus/imap[6209]: badlogin: server.example.com [se.rv.er.ip] plaintext @example.com SASL(-13): authentication failure: checkpass failed Dec 11 09:10:02 server cyrus/imap[6383]: badlogin: server.example.com [se.rv.er.ip] plaintext @partmaster.de SASL(-13): authentication failure: checkpass failed Dec 11 09:15:02 server cyrus/imap[7402]: badlogin: server.example.com [se.rv.er.ip] plaintext @partmaster.de SASL(-13): authentication failure: checkpass failed

Also alle 5 Minuten versucht sich ein lokaler Dienst des UCS-Servers am Cyrus-IMAP-Server anzumelden und diese Anmeldung schlägt fehl.
Im Nagios habe ich keine Regel gefundne, die den IMAP-Server prüft. Mit Wireshark sehe ich die Netzwerk-Kommunikation, aber finde den Client-Prozess nicht.

Wer macht sowas? Und warum? Wie bekomme ich das weg?


#2

OK - nun bin ich einen großen Schritt weiter gekommen. Ich habe mit

tshark -n -i lo  -f "port 143"

den Traffic auf der Schnittstelle lo belauscht und gleichzeitig mit

while true;  do pstree -pAal >> pstree.out ; lsof -i >> lsof.out ;  done

mitgeschrieben, welche Programme welche Ports öffnen.

Der verursachende Prozess ist

Der verursachende reminders-Lauf wird via cron in /etc/cron.d/kronolith2 angestossen.

Nun muss ich noch rausfinden, wie ich kronolith so konfigurieren muss/kann, dass er sich ordnungsgemäß am IMAP-Server anmeldet.
Kann mir da jemand Hinweise zu geben?

PS: Ich hatte UCS zuerst in Version 2.0 und ohne UGS installiert, UGS wurde dann nachinstalliert. Womit wohl ein paar Einstellungen “hinten runter gefallen” sind.


#3

Und in /var/log/horde/horde3.log ist eine verwertbare Fehlermeldung:

HORDE [info] [kronolith] NO, Login failed: authentication failure [pid 22748 on line 84 of "/usr/share/ horde3/lib/Horde/Share/kolab.php"]

Nun scheint es, dass der aufrufende Benutzer nicht herausgefunden wurde. Weil das Skript ja von der Kommandozeile (CLI) lief.


#4

Hallo,

vielen Dank für die ausführlichen Untersuchungen und die Fehlerbeschreibung. Wir konnten das Problem reproduzieren und haben dazu einen Eintrag in unserem internen Bug-Tracking System angelegt. Bisher konnten wir keine Fehlfunktionen im Bezug auf die genannten Fehlermeldungen feststellen - gibt es in Ihrer Umgebung Funktionseinschränkungen?

Mit freundlichen Grüßen
Janis Meybohm


#5

Es sollte keine Funktionseinschränkungen geben.

Wie schon beschrieben: Ich habe manuell von UCS.0-0 auf UCS+UGS aktualisiert, d.h. die LDAP-Benutzererinträge manuell erweitert. Sie enthalten nun jedoch alle felder, die auch die automatische Installation von GS mit angelegt hätte.

Nun vermute ich, dass kronolith zu einer bestimmten E-Mail-Adresse (z.B. systemmail@…) eine Identität sucht, um dessen Credentials bei der Authentifizierung zu nutzen?


#6

Hallo,

bisher wurden die Hintergründe zu diesen Meldungen noch nicht eingehend untersucht, sodass ich zum jetzigen Zeitpunkt keine konkrete Aussage zu deren Ursache treffen kann. Zu einer der kommenden UCS Versionen werden wir uns diesem Problem aber annehmen.

Mit freundlichen Grüßen
Janis Meybohm