Problems with creating/running Virtual Ubuntu 18.04


#1

Hi there, i have a problem with running a virrtual machine (Ubuntu 18.04) on my UCS (4.3).
I have installed several virtual machines in UCS and they all work fine, 2x Debian 9 (stretch) 64bit and 1x Windows 10 64bit.
I installed an Ubuntu 18.04 64bit as well, the installation goes through without any errors.
8GB RAM, 75 GB HDD (qcow2). I am using UCS’ built-in VNC to follow the installation on screen
When the installation is finished, i eject the ubuntu-iso from the CD-ROM and restart that virtual machine. It starts but after a couple of seconds the screen of the machine in VNC (browser) is scramlbed and impossible to decifer. The machine seems running. I cannot access it via putty (virtual Ubuntu denies connection).
Has anyone come across this behaviour yet and has a solution ?
I have tried with LVM and without, qcow2 and raw, paravirtualized and not paravirtualized. No change.
Many thanks !


#2

Hi,

I would guess it is somehow related to screen settings in the virtual machine items.

Have you seenthis and the related solution here?
Even though it is for virtualbox I would assume UVMM setting accordingly should help, too.

/CV


#3

Hi,

did you solve your issue?
If not you could try the following:
Use virsh and set “video -> model” from “cirrus” to "vga.


#4

Hi Christian,

many thanks for your help. Unfortunately i was not able to solve my problem as i do not know how to use virsh for setting video model to vga.
I used “virtual machine manager” on a physical Linux Mint machine to change the graphic settings to vga, saved the machine and put it back on to the UCS. still no change, screen of Ubuntu machine still garbled.


#5

Hi,

I do not have the full command to be used. You will have to figure it out on your own somehow.

Either use virsh on the command line- virsh prints loads of help information by just typing “help”. Some doc can be found here.

Or you might edit the according .xml file to match your needs. Use command line, too.

One should work.

/CV


#6

Try increasing the memory size for the virtual VGA from 16 MB (16384KB) to something higher. I had the same issue and setting the value to 64MB (64000KB) solved the problem.


#7

For the record: Changing the type from cirrus to vga and extending the vram to 64000 solved the issue also for me.