Probleme nach Änderung der IP-Adresse


#1

Hallo,
ich habe einen aktuellen UCS DC installiert. Nach der Installation habe ich die IP-Adresse geändert. Nun startet der Samba Dienst nicht mehr.
Er sucht den DC Master unter der vorherigen IP-Adresse (alt: 192.168.10.222, neu 192.168.0.250).
Hier der Auszug aus dem Log:

[2019/05/15 22:23:52.037843, 0, pid=1255] …/…/source3/nmbd/nmbd_become_dmb.c:353(become_domain_master_browser_wins)
become_domain_master_browser_wins: querying WINS server from IP 192.168.0.250 for domain master browser name ISB<1b> on workgroup ISB
[2019/05/15 22:23:52.040963, 0, pid=1255] …/…/source3/nmbd/nmbd_become_dmb.c:237(become_domain_master_query_success)
become_domain_master_query_success:
There is already a domain master browser at IP 192.168.10.222 for workgroup ISB registered on subnet UNICAST_SUBNET.
[2019/05/15 22:24:14.072684, 0, pid=1255] …/…/source3/nmbd/nmbd_browsesync.c:251(domain_master_node_status_fail)
domain_master_node_status_fail:
Doing a node status request to the domain master browser
for workgroup ISB at IP 192.168.10.222 failed.
Cannot sync browser lists.

Wie kann ich das ändern ?


#2

In so einem Fall würde ich mal nach der IP in der LDAP suchen,
Auf dem Master als root ein

slapcat > datei.ldif

machen und dann mit deinem Lieblingseditor in der datei.ldif nach 192.168.10.222 suchen. Dann die entsprechenden UCS Objekte über die UDM ändern.


#3

Die alte Adresse des Servers kommt in der LDAP nicht vor !


#4

Was sagen denn deine DNS Einträge. Versuch doch mal mittels
host -t A hostname.domain.tld aufzulösen.
Da der samba standardmäßig an die Interfaces statt der IP gebunden wird liegt der Fehler wohl nicht in der smb.conf.
Die alte Adresse steht vielleicht nicht im Openldap von UCS aber möglicherweise noch im samba ldap wenn der sync nich geklappt hat.

Beste Grüße


#5

Hallo pider,

bei der Änderung der Netzwerkadresse wurden zwar die dns und dhcp Einträge erzeugt, bei den dhcp Optionen fehlte aber die dns-Server option. Ich habe diese nachgetragen und jetzt funktioniert es.