Problem: During join a failed.ldif is created

Problem:

A new server (backupserver in this case) cannot join, because each time, an failed.ldif is created, with almost all ldap entries.
In the join.log you may find something like this:

Configure 03univention-directory-listener.inst Fri Jul 31 11:50:28 CEST 2026
2026-07-31 11:50:28.195362289+02:00 (in joinscript_init)
2026-07-31T11:50:28.423803+02:00     INIT 
2026-07-31T11:50:28.437514+02:00  PROCESS connecting to ldap://ucs-ma01.schein.me:7389
2026-07-31T11:50:31.230005+02:00  WARNING recyclebin: Listener module 'recyclebin' deactivated by UCRV "listener/module/recyclebin/deactivate".
2026-07-31T11:50:31.242820+02:00  WARNING initializing module replication
Warning: The file '/var/lib/univention-ldap/ldap/DB_CONFIG' is not registered as an UCR template.
slapd: Kein Prozess gefunden
Warning: The file '/var/lib/univention-ldap/ldap/DB_CONFIG' is not registered as an UCR template.
Starting slapd (via systemctl): slapd.service.
2026-07-31T11:50:35.581816+02:00    ERROR replication: Undefined attribute type; dn="ou=sun,dc=schein,dc=me": Error
2026-07-31T11:50:35.581847+02:00    ERROR       additional info: ucsschoolRole: attribute type undefined
2026-07-31T11:51:19.863842+02:00  WARNING finished initializing module replication with rv=0
2026-07-31T11:51:19.864102+02:00  WARNING initializing module ldap-cache-baa04df67e7af6bb0769f5cb7e72dba9
2026-07-31T11:51:21.246992+02:00  WARNING finished initializing module ldap-cache-baa04df67e7af6bb0769f5cb7e72dba9 with rv=0
2026-07-31T11:51:21.247325+02:00  WARNING initializing module udm_rest_reload
2026-07-31T11:51:21.984595+02:00  PROCESS udm_rest_reload: Reloading UDM REST API

Investigation:

These entries in the listener.log indicate that there was a problem with the schema replication

listener.log

2026-07-31T11:28:58.359459+02:00     INIT
2026-07-31T11:28:58.374491+02:00  WARNING Notifier/LDAP server is ucs-ma01.schein.me:7389
2026-07-31T11:28:58.374504+02:00  PROCESS connecting to ldap://ucs-ma01.schein.me:7389
2026-07-31T11:29:00.995897+02:00  WARNING recyclebin: Listener module 'recyclebin' deactivated by UCRV "listener/module/recyclebin/deactivate".
2026-07-31T11:29:01.240339+02:00  WARNING handler: replication (not ready)
2026-07-31T11:29:01.240353+02:00  WARNING handler: replication (failed)
2026-07-31T11:29:01.245215+02:00  WARNING Set Schema ID to 56
2026-07-31T11:29:01.245252+02:00  WARNING initializing module replication
slapd: Kein Prozess gefunden
Warning: The file '/var/lib/univention-ldap/ldap/DB_CONFIG' is not registered as an UCR template.
slapd: Kein Prozess gefunden
Warning: The file '/var/lib/univention-ldap/ldap/DB_CONFIG' is not registered as an UCR template.
Starting slapd (via systemctl): slapd.serviceJob for slapd.service failed because the control process exited with error code.
See "systemctl status slapd.service" and "journalctl -xeu slapd.service" for details.
 failed!
2026-07-31T11:29:05.491806+02:00  WARNING replication: Can't contact LDAP server: Can not connect LDAP Server, retry in 10 seconds
2026-07-31T11:29:05.491825+02:00  WARNING       additional info: Transport endpoint is not connected

Solution

Get the schema from the primary.
On you joining system:

/usr/share/univention-directory-listener/univention-get-ldif-from-master.py -s

After that try univention-join again.