OX - Failed to load messages, server unreachable

open-xchange

#1

Dear Forum
Latest UCS (4.2.4) with OX was running proper until using with licensed version (10 user license).
I added the credentials, updated packages and after that I get in OX Mail the message:
Error: Failed to load messages, server unreachable”. Drive, Calendar etc. seem to work proper.
Dovecot & Postfix are running. Tried it with an email client and is working.
Checked in OX settings email, tried same with email client - ok.
Checked passwords according (OX App Suite can not open Mail tap after update to UCS 4.2 and Open Xchange 7.8.3) - ok.

OX Error Log shows:

403 Forbidden 6/8/2018 1:55 PM
/appsuite/api/mail
Hide request body
{
  "action": "all",
  "folder": "default0/INBOX",
  "columns": "102,600,601,602,603,604,605,606,607,608,610,611,614,652,656,X-Open-Xchange-Share-URL",
  "sort": 610,
  "order": "desc",
  "timezone": "utc",
  "limit": "0,50",
  "session": "1a1038c8d391416cb260188cf1d826d7"
}

Any idea?

Best regards.


#2

Can you check log file?
/var/log/open-xchange/open-xchange.log.0


#3

The log shows:

2018-06-08T17:49:03,462+0700 INFO  [OXWorker-0000167] com.openexchange.guard.servlets.GuardServletAction.logAction(GuardServletAction.java:216)
Command sent "login" from IP xx.xx.xx.xx
 com.openexchange.grizzly.method=POST
 com.openexchange.grizzly.queryString=action=login&time=1528454945917&session=78fe320ce82d48a5b4c7a694603301ea
 com.openexchange.grizzly.remoteAddress=xx.xx.xx.xx
 com.openexchange.grizzly.remotePort=46468
 com.openexchange.grizzly.requestURI=/oxguard/login
 com.openexchange.grizzly.serverName=ucs.domain.com
 com.openexchange.grizzly.servletPath=/oxguard/login
 com.openexchange.grizzly.threadName=OXWorker-0000167
 com.openexchange.grizzly.userAgent=Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
 com.openexchange.request.trackingId=1902372249-951186660
 com.openexchange.session.contextId=10
 com.openexchange.session.sessionId=78fe320ce82d48a5b4c7a694603301ea
 com.openexchange.session.userId=8

#4

Hi there,

I assume the reason are the security headers set by default @UCS.
Does someone know where to set these security headers? Are there UCS variables again?
Is it possible to set these headers by default for all sites/apps or can this be done indvidually for each site/app?


#5

Das war es leider auch nicht :frowning: That wasn’t it, unfortunately.
I made a rollback, just UCS & OX, checked certificates (Apache, Dovecot and Postfix) - send and receive - ok. OX works proper. Entered customer ID, PW and license number, update. Same error.


#6

Hello Xela,

Unfortuately the snippet from the log you sent, does not give a clue on what’s going wrong.

How did you performed the update? Via univention-upgrade or via UMC?
Have you updated all packages?
Were there any error messages during the update?
Please have a look at /var/log/univention/updater.log
Have you restarted Open-Xchange? → service open-xchange restart
What does dpkg --audit return?
Are there any errors/warnings in /var/log/open-xchange/open-xchange.log.0 ?

Best regards,

Sönke