OX appsuit unavailable after upgrading from UCS 4.1 zu 4.3.3 so far

Hi there,
we inherit an older USC system and went to the updates now.
The system was on version 4.1.x :thinking: :tired_face: and is now on 4.3-3 errata520 and ox is at version 7.10.1-ucs3 since yesterday night.
We had a long term of updates to do including switch ipmad from cyrus to dovecot.
All is fine now except accessing OX Appsuite.

When we try to open https://mail.domain.tld/appsuite/ we get

Forbidden

You don’t have permission to access /appsuite/ on this server.

In apache2/error.log we found:

[Fri Jan 28 11:42:32.204080 2022] [autoindex:error] [pid 20989] [client 62.54.145.43:64428] AH01276: Cannot serve directory /var/www/appsuite/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

Cause this machine is our only OX customer we don’t have a chance to compare the systems.

It’s obviusly we have to update the machine further, but the user now hav no mails, cause of companys “OX only” policies to access the mails. gnaaar

Any hint we can follow to reattach the appsuite quickly until the next maintenance window?

Regards
Stefan

I’d say there might be something wrong with the apache2 configuration. All join scripts finished successfully?

Hi audiolinux, thanks for your answer.

Where can I check this? I tried to figure out where are some installations log for appsuite kan be found, but i have no clue. During UCS update there are logs with 13000 and more lines. While updating Apps ucs onl shows a bar with tasknames.

I figured out:
root@mail:~# univention-check-join-status
Joined successfully

Problem still exist …

Anyone, any suggestions where I can look after the blocked gear?

Maybe it is something around the Apache Directory Index ? You might check first the this or similar in infos regarding: No matching DirectoryIndex ?

Okay, I will take a look at that. But how it has to be? This is the only OX we are take care about.
Could you give me a peek in a directory of a correct running OX?

After quite a lot of try and error, I found a most obscure apache2 behavior:

The /etc/apache2/sites-enabled/ox.conf had the following directive: <Directory /var/www/appsuite/>

but /var/www/appsuite/ was just an empty directory, the actual program now resides in /var/www/html/appsuite/, so I changed the directive to <Directory /var/www/html/appsuite/>

After a reload of apache, the “Forbiddden” was gone, but now I could only see an empty directory (which according to the dates) was the empty “/var/www/appsuite/” not “/var/www/html/appsuite/”.

I kept <Directory /var/www/html/appsuite/> in the config, but moved the data from /var/www/html/appsuite/ to /var/www/appsuite/ and now ox works.

It seems my apache ignores a part of the directory path!?
<Directory /var/www/html/appsuite/>

Anybody ever had such a problem? Anybdoy got a clue where it stems from?

Hi @BEE.GMBH,

Thanks for sharing

For me the command;

file /var/www/appsuite

gives out a:

/var/www/appsuite: symbolic link to html/appsuite

And the directory /var/www/html/appsuite is populated with the files you’ve mentioned. This looks like the correct way to set it up. Maybe your symbolic link was broken ?
As it is working now, take your time to check this in a secure environment and go for a longterm solution.
I am sure you know each update/upgrade can interrupt your actual setting.

1 Like

I think, the old installation was actually under /var/www/appsuite and because of this, the upgrade failed to create a symlink to /var/www/html/appsuite in it’s place (perhpaps inssuficient rights to remove the old folder?).

That could explain the error, but I’m still kinda curious about apache’s behavior (But I think here’s not the right place to go into details about apache :slight_smile: )

Currently I have the program files under /var/www/html/appsuite and a symlink /var/www/appsuite pointing to it, just to be in line with other installs.

Thank you.