OpenVPN + Default Gateway

german

#1

Hallo zusammen,

ich habe folgendes Verständnisproblem im Zusammenhang mit OpenVPN + Default Gateway:
Auf einem UCS ist openVPN4UCS installiert und eingerichtet:


Der Haken bei “OpenVPN Standard-Gateway Umleitung” ist NICHT gesetzt.

Auf einem Windows Client außerhalb des Netzes habe ich das Ready2Go Paket heruntergeladen und die Konfiguration in das “config” Verzeichnis von OpenVPN (Version 2.3.12-I601) kopiert, die Verbindung wird erfolgreich hergestellt, ich kann auf Dienste des entfernten Netzes zugreifen, soweit alles gut.

ABER:
Wenn die Verbindung per VPN hergestellt ist, wird jeglicher Internetverkehr über das VPN geroutet, OBWOHL der Haken nicht gesetzt ist (s.o.).
Traceroute ergibt das:

[code]C:\Users\user>tracert www.heise.de

Routenverfolgung zu www.heise.de [193.99.144.85]
über maximal 30 Hops:

1 41 ms 39 ms 40 ms 192.168.150.1 <----- VPN GATEWAY
2 41 ms 40 ms 38 ms 192.168.x.x
3 59 ms 54 ms 54 ms bras-vc2.netcologne.de [195.14.226.125]
4 55 ms 54 ms 57 ms ip-core-eup1-ae12.netcologne.de [89.1.16.157]
5 54 ms 52 ms 54 ms ip-core-sto1-xe1-0-10.netcologne.de [87.79.17.18]
6 66 ms 65 ms 55 ms rtdecix-po9.netcologne.de [89.1.16.2]
7 68 ms 66 ms 63 ms te0-0-2-3.c350.f.de.plusline.net [80.81.193.132]
8 67 ms 65 ms 63 ms 82.98.102.5
9 64 ms 59 ms 60 ms 212.19.61.13
10 74 ms 70 ms 69 ms www.heise.de [193.99.144.85]

Ablaufverfolgung beendet.[/code]

Das ist die Routingtabelle auf dem Windows Client, wenn die VPN Verbindung steht:

[code]IPv4-Routentabelle

Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.42.1 192.168.42.189 5
0.0.0.0 128.0.0.0 192.168.150.1 192.168.150.3 20
.
.
.
128.0.0.0 128.0.0.0 192.168.150.1 192.168.150.3 20
192.168.1.0 255.255.255.0 192.168.150.1 192.168.150.3 20
.
.
.
===========================================================================[/code]

Der erste Eintrag ist korrekt, das ist das normale Default Gateway des lokalen Netzes des Windows Client.
Nun irritiert mich ein wenig der zweite Eintrag, wo das Default Gateway auf das VPN-Gateway gesetzt ist, jedoch mit Subnetz Maske 128.0.0.0 … wo kommt dieser Eintrag her? Ist der für das Routing über das VPN verantwortlich? Der nicht gesetzte Haken im UCS suggeriert doch etwas anderes…

Oder hab ich hier noch etwas nicht verstanden?

Vielen Dank schon mal und viele Grüße
T0mcat


#2

Hallo,

ich habe die OpenVPN-Integration nicht im Einsatz und kann daher nicht direkt nachsehen.

Nach Lage der Dinge würde ich vermuten, dass die Option im Bild entweder die Serverkonfiguration “push redirect-gateway …” oder die Clientkonfiguration “redirect-gateway” setzt.
Es wäre zu prüfen, was der Fall ist und wie sich die Veränderung der Option in der UMC auf die Server- oder Clientkonfiguration auswirkt.

Viele Grüße,
Dirk Ahrnke