NFSv4 doesn’t work anymore

Very strange behavior. I don’t know since when, but with 4.4-6 errata796 I cannot mount NFS share anymore, with or without kerberos doesn’t matter. Any suggestion?

Hi hidalgo,

I am unfortunately no Exprte. What says then:
systemctl status nfs-server.service

Am Client:
showmount -e [Servername]

Use the -vvv option for the mount command. Do you get errors here?Are there any error messages in the logfile on the server?

with best
sven

I got something like

showmount -e fp-files
Export list for fp-files:
/home *

but I get

mount -vvv -t nfs4 -o sec=krb5p fp-files:/home /mnt
mount.nfs4: timeout set for Tue Nov 10 08:47:00 2020
mount.nfs4: trying text-based options 'sec=krb5p,vers=4.2,addr=12.45.67.8,clientaddr=12.45.67.9'
mount.nfs4: mount(2): Permission denied
mount.nfs4: access denied by server while mounting fp-files:/home

Alltough it seems that something is wrong with Kerberos, I got the same error without sec=krb5p

can you mount the share without Kerberos?

As I mentioned before. Neither works without Kerberos. :cry:

What kind of client is it? Ubuntu? version?

How did you take the client into the domain? UCS join script or ADS join?

Now I got it running again. I don’t know exactly what it was. After a restart I missed the the NFS-kerberos-ticket in the key tab. So I added it again and now it works again as it should.