Mails werden nicht auf Spam geprüft

german

#1

Hallo,

nachdem ich am Wochenende meinen ct-Server neu aufgesetzt habe, fällt mir auf, dass keine Spamprüfung mehr gemacht wird. Im Header der Mails ist kein “X-Spam*” Eintrag mehr drin:

Received: from localhost (localhost [127.0.0.1]) by *.*.lan (Postfix) with ESMTP id 63070120059D for <*@*.de>; Tue, 19 Mar 2013 14:10:34 +0100 (CET) X-Virus-Scanned: by amavisd-new-2.6.4 (20090625) (Debian) at *.lan Received: from *.*.lan ([127.0.0.1]) by localhost (*.*.lan [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id MsZI4uE+o8-V for <*@*.de>; Tue, 19 Mar 2013 14:10:33 +0100 (CET) Received: from *.*.lan (localhost [127.0.0.1]) by s*.*.lan (Postfix) with ESMTP id 96B5C1200523 for <*@*.de>; Tue, 19 Mar 2013 14:10:33 +0100 (CET) X-Original-To: *@*.de Delivered-To: *@xa0.serverdomain.org Received: from *.de [*.*.*.138] by *.*.lan with POP3 (fetchmail-6.3.18) for <*@*.de> (single-drop); Tue, 19 Mar 2013 14:10:33 +0100 (CET) Received: from mail.univention.de (mail.univention.de [82.198.197.8]) by xa0.serverdomain.org (mail.xa0.serverdomain.org) with ESMTPS id 01EFA4760A148 for <*@*.de>; Tue, 19 Mar 2013 14:09:51 +0100 (CET) Received: from dimma.knut.univention.de (dimma.knut.univention.de [192.168.0.193]) by strala.knut.univention.de (Postfix) with ESMTP id BA19A62BCA for <*@*.de>; Tue, 19 Mar 2013 14:09:51 +0100 (CET) Date: Tue, 19 Mar 2013 14:09:51 +0100 From: Univention Errata Updates <announce_noreply@univention.de> To: MarkusH <*@*.de> Subject: Univention errata update 73 for Univention Corporate Server 3.1 Message-ID: <20130319130951.GA24859@dimma.knut.univention.de> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline User-Agent: Mutt/1.5.20 (2009-06-14) Content-Transfer-Encoding: quoted-printable

Der Virenscan läuft. Der Spamassasin-Dienst läuft auch. Die Registry Variable ist mail/antivir/spam steht auf “yes”.

Was könnte ich noch probieren? Das ganze System neu gestartet habe ich auch schon.


#2

push

Keiner eine Idee?


#3

Nicht viel los hier, dann antworte ich mir mal selber. Anscheinend ist da beim installieren irgendwas nicht richtig gelaufen. Der Fehler lag in der amavis Konfiguration in der Datei 60-univention. Folgende Zeile:

@local_domains_acl = ( “.$mydomain” );

hab ich ausgebessert in

@local_domains_acl = qw( Name-meiner-Maildomain );

Und schon gehts!

Nächste Frage: Vermutlich wird das beim nächsten Update wieder überschrieben, muss ich da jetzt ein eigenes template anlegen`?

Markus


#4

Hallo,

es handelt sich hierbei um ein UCR-Template.
Das entsprechende Attribut in der Amavis-Konfiguration wird automatisch wie von Ihnen gewünscht gesetzt, wenn Sie die folgende UCR-Variable setzen:

ucr set mail/hosteddomains=<domainname>

Zum Verständnis gern ein kurzer Auszug des Templates (/etc/univention/templates/files/etc/amavis/conf.d/60-univention):

[code]@!@
key = ‘mail/hosteddomains’
if baseConfig.has_key(key) and baseConfig[key]:
if baseConfig.has_key(‘scalix/smtpfilter’) and baseConfig[‘scalix/smtpfilter’].lower() in [‘yes’, ‘true’]:
print ‘@local_domains_maps = qw( %s );’ % baseConfig[key]

    print '@local_domains_acl = qw( %s );  # hosted mail domains' % baseConfig[key]
    print '# @local_domains_acl = ( ".$mydomain" );  # $mydomain and its subdomains'

else:
print ‘@local_domains_acl = ( “.$mydomain” ); # $mydomain and its subdomains’
@!@[/code]

Mit freundlichen Grüßen,
Tim Petersen


#5

Welchen Sinn haben eigentlich die Scalix UCR-Variablen im Mailstack von UCS 3.x?


#6

Hallo,

es handelt sich hierbei um eine historische Stelle im Code welche in einer kommenden Version noch einmal überarbeiten werden wird (auf den ersten Blick habe ich im Mailstack auch nur diese Stelle gefunden, wo alte scalix/* Variablen referenziert sind) - dennoch danke für den Hinweis.

Mit freundlichen Grüßen,
Tim Petersen