Liste der "Kolab Home Server" ist leer

mail
german

#1

Hallo,
wenn ich die Groupware-Option bei einem User aktivieren möchte, muss ich einen “Kolab Home Server” eintragen. Die Liste ist jedoch leer und keine eigene Eingabe wird akzeptiert. Wie ist zu verfahren?

Danke,
Marc


#2

Hallo,

damit in der Liste eine Auswahl möglich ist, muss auf mindestens einem System in der Domäne der Kolab-Server installiert und dieses System gejoined sein. Die Installation kann z.B. mit univention-system-setup-software und Auswahl der “Kolab2 für UCS” Komponente erfolgen.

Mit freundlichen Grüssen
Tobias Scherer


#3

Hallo,
ich habe nur einen UCS-Server, auf dem Kolab auch installiert ist. Weitere Rechner in der Domäne gibt es nicht. Ich habe den Haken im software-setup schon einmal gelöscht und nach der restlosen Deinstallation wieder neu eingefügt, um Kolab neu zu installieren, aber das hat auch nicht geholfen.

Im LDAP-DIrectory tauchen auch Kolab-Einträge auf (KolabDefaultServer oder so ähnlich). Ich kann mal probieren, die passende objectClass und das KolabHomeServer-Attribut händisch bei einem User im LDAP einzufügen, aber das kann ja nicht Sinn der Sache sein.

Grüße
Marc


#4

Hallo,

was für ein Browser wird für die Bedienung des UDM verwendet? Ist der Benutzer mit dem Groupwaretemplate angelegt worden?

Um die Option händisch zu setzen kann auch das UDM Command Line Interface verwendet werden:

eval $(univention-config-registry shell) univention-directory-manager users/user modify \ --dn="uid=<USER>,cn=users,$ldap_base" \ --set kolabHomeServer="<FQDN>"

Mit freundlichen Grüssen
Tobias Scherer


#5

Ich habe es mit Opera und Firefox unter Linux probiert. Auf einer anderen Installation hat es aber mit denselben Browsern funktioniert.

Das Groupware-User-Template habe ich ausgewählt.

Danke für den Kommandozeilenbefehl, den werde ich mal testen.

Gruß
Marc


#6

Hallo,

hat das geholfen?

In der Liste tauchen die Server auf, bei denen kolab2 als Dienst aufgeführt ist. Reiter “Dienste” beim Bearbeiten des Rechners.
Ggf. muss der Server auch einen DNS-Eintrag besitzen, da bin ich mir aber gerade nicht ganz sicher.

Viele Grüße
Stefan Gohmann


#7

Ah, das hat geholfen. Der Dienst war aktiv, aber die IP-Adresse war im DNS_Reiter nicht korrekt eingetragen. Sobald ich dort die korrekte Adresse angelegt und eingetragen hatte, war auch der Eintrag des Kolab-Servers vorhanden.

Danke für den Tipp :slight_smile:

Das ist aber wirklich schwierig zu finden und könnte besser Dokumentiert sein.


#8

Ja, ich habe dazu einen Bug gegen unsere Dokumentation erstellt:
forge.univention.org/bugzilla/s … i?id=17777

Viele Grüße
Stefan Gohmann