Lets Ecrpt does not work - domain chaos?

Hi there,

iam still new to UCS and hope someone can help me out.
Main main problem is missing https support as well as nextcloud does not trust my domain (only ip works)

I do have server running ucs. So far that worked out.
However, i want the server to be avaviable under https://ucs.mydomain.com

So i used my domain made a new dns entry to and created an letsCrypt on that domain for ucs.mydomain.com.

I can access my server with ucs.mydomain.com, but it is “unsafe”.
However, nextcloud does not trust the adress and therefore blocks my request. ucs.mydomain.com/nextcloud. does work.

I also installed the LetsEcrypt App from the UCS store and added ucs.mydomain.com there.
Still the same problem. i guess i messed something up something when i installed the UCS server in the first place.

Could some help me about this?

univention-app shell nextcloud sudo -u www-data php /var/www/html/occ config:system:get trusted_domains

that would give you for e.g.


as the list in config.php starts with position 0 (zero) you’ll get entry numbers 0-1 so you have to add new entry with id 2

univention-app shell nextcloud sudo -u www-data php /var/www/html/occ config:system:set trusted_domains 2 --value ucs.mydomain.com

also see: Edit config php for trust domain. what is the command? what is the path? - #2 by ahrnke


1 Like

Thank you Cristian,

iam logged into the server as Administratos@ucs:1234

Bildschirmfoto von 2022-11-23 15-21-26

Which version of UCS are you running. The current version is 5. It looks like you might be running version 4 based on the error messages in that screen shot.

Is this a new install? If it is I would suggest starting over with version 5 if possible.

1 Like

you have to login as root user on cli not administrator - per default it’s the same password for both - except you changed administrator password after installation then the root password is kept original

p.s. never use the administrator on cli (its not an admin there)


1 Like

@Kevo it was 5.0.1 but i updated it this morning (before I posted here) to 5.0.2.
So it is 5.0.2 when i made the screenshot.

Thank you i wasent aware of this.
This worked like a charm.

When i want to override a domain. i just set the value for its according number?
Lets say i want to change ucs.mydomain.com to ucs.mynewdomain.com I just use the command above.

univention-app shell nextcloud sudo -u www-data php /var/www/html/occ config:system:set trusted_domains 2 --value ucs.mydomain.com

Nextcloud does work fine now.

But, I totally misses my second point:
The server adress is still “unsecure” as its ssl certificate is not correct.