lastLogon time stamp appears to be wrong

I am trying to create a script that will track lastLogonTimestamp of univention-s4search
The time showing appears to be wrong.

Problem: Time is being displayed wrong on univention-s4search

Trouble shooting performed:

  1. Login to univention web interface as “myusername”
  2. I used the following command at 11:43am 3/1/2020 -5:00 EST
    univention-s4search cn=myusername | grep last
    Output:
root@ucs01-v:/# univention-s4search cn=admindh | grep last
lastLogoff: 0
lastLogonTimestamp: 132272023081040950
lastLogon: 132274836179713020
  1. I tried using this site to make a conversion of “lastLogonTimestamp” value https://www.epochconverter.com/ldap
    Conversion shows

Epoch/Unix time : 1582728708
GMT : Wednesday, February 26, 2020 2:51:48 PM
Your time zone : Wednesday, February 26, 2020 9:51:48 AM GMT-05:00

I tried using the same site to make a conversion of “lastLogon” value
Conversion shows:

Epoch/Unix time : 1583010017
GMT : Saturday, February 29, 2020 9:00:17 PM
Your time zone : Saturday, February 29, 2020 4:00:17 PM GMT-05:00

  1. Performing date in Univention shows:
    Sun Mar 1 11:43:53 EST 2020

Questions:
Is the conversion wrong? Also another thing that is odd is when I log out and log back in, and check the values again, they do not change.

I followed the guidance of this post, am I missing something?

My end goal is to build a script that monitor these values and write to a log or perform a conditional against them. I have read posts from a few years ago that this is not a standard feature UCS provides. Still the case?