Kolab Chwala Backend on UCS 4.1-1 broken?

german

#1

Hallo Zusammen,

ich hab gerade einen neuen UCS 4.1-1 erata 121 aufgesetzt und auf diesem Kolab installiert.
Wenn ich mich nun im Webinterface von Kolab anmelde, sehe ich meine eMails und kann auch schreiben.
Keine weiteren Anpasungen,
Wenn ich mir Dateien im Chwala ansehen will, kommt nur eine fast blanke Seite.
Irgend was scheint mit dem Chwala Backend nicht zu funktionieren.
Ich bekomme jedoch nichts in den Logdateien.
Hat irgend jemand die gleichen Probleme?

Ich hoffe die Frage ist hier richtg und gehört nicht “rüber” zu kolab.org ins Forum…

Wenn ich Seafile als Backend an Kolab anbinden möchte, bleibt ebenso die Seite blank.
Dabei habe ich mich an diese Anleitung gehalten: docs.kolab.org/howtos/use-seafi … hwala.html
Auf einem anderen UCS vor 3Wochen hat es talellos geklappt.
Egal was ich an Debuginfo einschalte, ich bekomme nichts in die Logdatein…
Wenn ich in der /etc/roundcubemail/config.inc.php
debug_level =1 und devel_mode = true setze, bekomme ich die einzige
“Mikrospur”:
[29-Feb-2016 00:57:31,000000 +0100]: <0dri4ok4> PHP Error: Curl error: SSL: certificate subject name ‘xxxxxxxxxx.xxxxx’ does not match target host name ‘192.168.3.2’ in /usr/share/roundcubemail/plugins/kolab_files/lib/kolab_files_engine.php on line 1143 (GET /webmail/c74669e413383cd3/?_task=files)
Hat irgend jemand noch eine Idee??
Vielen Dank!
HB


UCS 4.0-3, Kolab mit Fetchmail und Relay Host
#2

Sorry wenn das nun nicht dazu gehört!

Wie ist das bei dir mit E-Mailempfang?
Ich bekomme bei Kolab nie E-Mails sondern immer nur Mailer Daemons


#3

Hallo Zusammen,

also der SSL Hinweis war in der Tat wichtig.
Durch Zufall habe ich entdeckt, dass unter http alles funktioniert.
Nur unter https funktioniert es nicht… :frowning:
Nun versuche ich weiter zu verstehen, warum…

Beste Grüße
HBAU


#4

[quote=“csaeum”]Sorry wenn das nun nicht dazu gehört!

Wie ist das bei dir mit E-Mailempfang?
Ich bekomme bei Kolab nie E-Mails sondern immer nur Mailer Daemons[/quote]

Hallo csaeum,
äh… ohne die Fehlercodes in den Mailerdeamons ist es etwas schwer zu sagen, wo das Problem steckt. Das kan …äh… gelinde gesagt recht viele Ursachen haben.
Prinzipiell funktioniert bei mir mail empfang und versang ganz gut.
Ich habe allerding diese Anpassungen gemacht;

in der /etc/unvention/templates/files/etc/postfix/50_restritions für die main.cf
die folgenden Zeilen unbedingt asukommentieren, da sonst keine eMails angenommen werden oder versendet werden!
#smtpd_data_restrictions = check_policy_service unix:private/sender_policy_incoming
#submission_data_restrictions = check_policy_service unix:private/submission_policy
mit

ucr commit /etc/postfix/main.cf 

aktivieren

Dabei hat mir dieser Thread geholfen:
https://help.univention.com/t/windows-vertrauensstellung/118/1

Leider habe ich bis jetzt noch nicht rausbekommen, wo für diese policies verwendet werden…

Beste Grüße
HBAU


#5

Danke für die Antwort werde ich gleich mal testen :slight_smile:

Ich suche danach schon einige ZEit und habe auch hier im Forum usw gefragt. Auch bei Kolab im IRC war ich deswegen schon.

Gruß


#6

Also der vollständigkeit halber… ich habe nun eine Umgehungslösung gefunden…

in der Datei:
/etc/univention/templates/files/etc/roundcubemail/config.inc.php
kurz vor dem Ende den Schalter für ssl Überprüfung des hosts von default = true auf false stellen:

    $config['kolab_http_request'] = Array(
            'ssl_verify_host' => false,
            'ssl_verify_peer' => true,
            'ssl_cafile'     => '/etc/univention/ssl/ucsCA/CAcert.pem'

und das ganze wieder mit :

 ucr commit /etc/roundcubemail/config.inc.php

aktivieren…

Nun funktioniert es.
Wenn mir das jemand bei Gelegnheit erklären kann, freue ich mich :slight_smile:
Beste Grüße


#7

hbau du bist heute mein Held.

Sei November habe ich gesucht und in Foren gefragt.

Dabei waren es die 2 Kommentarzeichen.

Danke nun kann ich Kolab endlich richtig einsetzen.


#8

[quote=“csaeum”]hbau du bist heute mein Held.

Sei November habe ich gesucht und in Foren gefragt.

Dabei waren es die 2 Kommentarzeichen.

Danke nun kann ich Kolab endlich richtig einsetzen.[/quote]

Vielen Dank fürdie Blumen. Gern geschehen! :slight_smile: