Kix2017 no login


#1

Hi, this are my assets:
1 UCS Master ucs-8023
1 UCS Slave ucs-7758

I’ve installed Kix2017 on ucs-7758
I’ve rejoint ucs-7758

I’m tring to login into kix2017 with administrator credential ----> Login failed! Your user name or password was entered incorrectly.
I’m tring to login into kix2017 with domain users credentials —> Login failed! Your user name or password was entered incorrectly.


#2

Hi,

I suppose it’s a UCS 4.1 you are using. Is KIX 2017 the only KIX that is installed or do you have KIX 2016 installed too ? Can you please check the LDAP configuration in /opt/kix/Kernel/Config.pm ? There must be some entries regarding authentication.

best regards,
Rene


#3

UCS 4.2-2
yes I’ve 2016 installed, now 2017
in /opt/kix/Kernel/Config.pm
https://pastebin.com/MDqp8zwJ

from kix_log:
could not connect to server: Connection refused
Is the server running on host “localhost” (127.0.0.1) and accepting
TCP/IP connections on port 5432?

[Fri Nov 24 09:47:24 2017][Error][Kernel::System::Auth::LDAP::Auth][194] First bind failed! Invalid credentials
[Fri Nov 24 09:47:24 2017][Error][Kernel::System::Auth::LDAP::Auth][194] First bind failed! Invalid credentials
[Fri Nov 24 09:47:24 2017][Error][Kernel::System::User::UserLookup][969] No UserID found for ‘administrator’!

but
systemctl status postgresql
● postgresql.service - PostgreSQL RDBMS
Loaded: loaded (/lib/systemd/system/postgresql.service; enabled)
Active: active (exited) since ven 2017-11-24 08:01:42 CET; 1h 43min ago
Process: 24474 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 24474 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/postgresql.service

nov 24 08:01:42 ucs-7758 systemd[1]: Started PostgreSQL RDBMS.

Thanks
Andrea


#4

Hi Andrea,

thanks for the response. How have you been able to install KIX 2016 on UCS 4.2 ? Or did you upgrade the OS after installing KIX 2016 ?

The error message “First bind failed!” means that the “kixldapusr” is not able to do the LDAP “login”. Can you please check whether this user exists in UCS or not ?

best regards,
Rene


#5

I’ve removed 2016 and installed 2017.
Thre is kixldapusr on LDAP
…mmmmm


#6

I don’t know what caused this problem, but to make it work again please set a new password for the kixldap user and change the Config option “LDAPBindUserPw” in you Config.pm accordingly. Also please change the file /etc/kixldap.secret with the new password.


#7

Thank you now works fine agents login, not customers
mmmmm

Andrea