Kein DHCP mehr nach Inst. von KVMM

german

#1

Guten Tag,

nach der Installation des KVMM auf einem UCS 4.01 bzw der damit verbundenen automatischen Einrichtung der bridge br0 werden keine leases mehr ausgegeben (syslog: “Ignoring requests on br0. If this is not what you
want, please write a subnet declaration in your dhcpd.conf file for the
network segment to which interface br0 is attached.”)

Ich habe bereits folgenden Hinweis:
"DHCP-Subnet für das IP-Subnetz von br0 erstellen "

Ein solches Subnetz besteht jedoch schon, siehe Anhänge. Oder muss das Subnetz noch an br0 gebunden werden? Ich wüsste aber nicht, wo oder wie das in der UMC geht!

Können Sie weiterhelfen?

Vielen Dank,
MfG,
Axel Voigt
Schul-Support-Service
Bremen

[code]root@odin:~# ifconfig
br0 Link encap:Ethernet Hardware Adresse 0c:c4:7a:06:31:a6
inet Adresse:10.101.212.5 Bcast:10.101.212.255 Maske:255.255.255.0
inet6-Adresse: fe80::ec4:7aff:fe06:31a6/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:2411 errors:0 dropped:5 overruns:0 frame:0
TX packets:1306 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:470739 (459.7 KiB) TX bytes:388701 (379.5 KiB)

eth0 Link encap:Ethernet Hardware Adresse 0c:c4:7a:06:31:a6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:2391 errors:0 dropped:0 overruns:0 frame:0
TX packets:1360 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:493329 (481.7 KiB) TX bytes:390278 (381.1 KiB)
Speicher:f7100000-f717ffff

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:65536 Metrik:1
RX packets:20943 errors:0 dropped:0 overruns:0 frame:0
TX packets:20943 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:3644825 (3.4 MiB) TX bytes:3644825 (3.4 MiB)

vnet0 Link encap:Ethernet Hardware Adresse fe:54:00:f1:60:45
inet6-Adresse: fe80::fc54:ff:fef1:6045/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:84 errors:0 dropped:0 overruns:0 frame:0
TX packets:1241 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:500
RX bytes:17750 (17.3 KiB) TX bytes:98941 (96.6 KiB)

root@odin:~#[/code]





#2

Hallo,

im Normalfall gibt es m.E. keine gerätespezifischen Konfigurationen vom DHCP. Eine Ausnahme ist “/etc/default/isc-dhcp-server”, das sollte man aber wohl als Letztes probieren.

Sowohl die Informationen aus ipconfig als auch die aus den Screenshots sehen eigentlich stimmig aus.
Ihre Information zur Subnet-Deklaration stammt bestimmt aus DHCP-Server does not start. Das ist soweit ich sehe erfüllt.

Wenn Sie wissen wollen, was aus der LDAP-basierten Konfiguration bei DHCP-Server ankommt, können Sie den Kommentar bei “ldap-debug-file” in /etc/dhcp/dhcpd.conf entfernen und nach einem Neustart von univention-dhcp im angegebenen Log nachsehen.

Viele Grüße,
Dirk Ahrnke


#3

Hallo Herr Ahrnke,

danke für Ihre Antwort. Weiter bin ich allerdings noch nicht:

Die Ausgabe von
less /var/log/dhcp-ldap-startup.log
nach dem Einkommentieren von
ldap-debug-file “/var/log/dhcp-ldap-startup.log”
in der
/etc/dhcp/dhcpd.conf
und
/etc/init.d/univention-dhcp stop
und
/etc/init.d/univention-dhcp start
lautet

#DHCP Service
option routers 10.101.212.1;
option domain-name “s3.intra”;
option domain-name-servers 10.101.212.5;
option wpad “http://odin.s3.intra/proxy.pac”;
/var/log/dhcp-ldap-startup.log (END)

… sieht doch gut aus, oder?

Die “Information zur Subnet-Deklaration” stammt nicht aus einem anderen Topic, wie Sie vermuten, sondern aus aus unserem eigenen syslog, hier nochmal komplett:


Apr 28 16:54:06 odin dhcpd: Wrote 0 leases to leases file.
Apr 28 16:54:06 odin dhcpd:
Apr 28 16:54:06 odin dhcpd: No subnet declaration for br0 (10.101.212.5).
Apr 28 16:54:06 odin dhcpd: ** Ignoring requests on br0. If this is not what
Apr 28 16:54:06 odin dhcpd: you want, please write a subnet declaration
Apr 28 16:54:06 odin dhcpd: in your dhcpd.conf file for the network segment
Apr 28 16:54:06 odin dhcpd: to which interface br0 is attached. **
Apr 28 16:54:06 odin dhcpd:
Apr 28 16:54:06 odin dhcpd:
Apr 28 16:54:06 odin dhcpd: Not configured to listen on any interfaces!

Können sie noch weiterhelfen?

merkwürdig: /etc/init.d/univention-dhcp restart funktioniert nicht (“failed”) (start und stop nacheinander aber wohl).

Das Verhalten, dass DHCP nach Aktivierung des KVMM nicht mehr läuft (weil auf anderem interface) ist also nicht default, richtig? Hätte mich auch gewundert.

MfG,
Axel Voigt


IP Vergabe für Computerkonto
#4

Hallo,

ich habe mal in einer Testinstallation angefangen, das Problem nachzustellen.

[code]root@m:~# udm dhcp/subnet list --superordinate cn=test4single.it25.de,cn=dhcp,dc=it25,dc=de

DN: cn=192.168.133.0,cn=test4single.it25.de,cn=dhcp,dc=it25,dc=de
ARG: None
subnet: 192.168.133.0
range: 192.168.133.200 192.168.133.210
broadcastaddress: None
subnetmask: 24

root@m:~# cat /var/log/dhcp-ldap-startup.log
#DHCP Service
option routers 192.168.133.254;
option domain-name “test4single.it25.de”;
option domain-name-servers 192.168.133.10;subnet 192.168.133.0 netmask 255.255.255.0 {
range 192.168.133.200 192.168.133.210;
option routers 192.168.133.254;
option domain-name “test4single.it25.de”;
option domain-name-servers 192.168.133.10;
[/code]

Bei Ihnen fehlt die Deklaration des Subnet mit dem Range in der dhcp-ldap-startup.log. Laut Bild müsste da irgendwo zumindest der Bereich 10.101.212.20 - 10.101.212.254 auftauchen. Ich bin etwas unsicher, ob das Problem wirklich nur mit der Bridge zu tun haben soll.

Viele Grüße,
Dirk Ahrnke


#5

Hallo Herr Ahrncke,

nochmal danke für Ihre Antwort.
Wir hatten ja noch andere Merkwürdigkeiten auf dem System, und weil das System noch nicht produktiv genutzt war, haben wir es nun neu aufgesetzt. Jetzt läuft alles gut. Was vorher schief gegangen ist, wissen wir nicht.

viele Grüße,
Axel Voigt