Joinen nur ueber eth0?

german

#1

Mein UCS-Server 2.0 verfuegt ueber 3 Netzwerkkarten. Dieser wurde bereits ueber eth0 (Kupfer) erfolgreich in die UCS-Domaene gejoint. Anschliessend wollte ich diese Konfiguration aendern und ihn stattdessen ueber das schnellere Interface eth2 (LWL) in die Domaene joinen, wozu ich die Konfiguration von eth0 entfernt und stattdessen auf eth2 hinterlegt habe. Dieser Vorgang schlaegt allerdings fehl. Er stoppt an der Stelle

Configure 05univention-bind.inst

Nachdem ich im dazugehoerigen Join-Script nachgeschaut habe (/usr/lib/univention-install/05univention-bind.inst), musste ich feststellen, dass scheinbar versucht wird, die nicht vorhandene Konfiguration von eth0 auszulesen um bind zu konfigurieren.

Meine Frage dazu:
Kann ich fuer den Join-Vorgang manuell ein anderes Interface als eth0 mitgeben oder muss ich tatsaechlich auf eth0 eine Konfiguration hinterlegen, selbst wenn ich dieses Interface ueberhaupt nicht nutzen moechte?


#2

Hallo,

vielen Dank für Ihren Hinweis.
Bisher ist es nicht möglich für den Join-Vorgang manuell ein andere
Netzwerk Schnittstelle anzugeben. Wir haben dazu einen Eintrag in unserer
internen Fehlerdatenbank vorgenommen. Dieses Problem wird in einer der
nächsten UCS Versionen behoben sein.

Wenn die Konfiguration von “eth0” und “eth2” identisch ist und die
Physische Verbindung über “eth2” besteht, dann brauchen Sie den Server
nicht erneut zu Joinen, die Server müssten auch so miteinander
Kommunizieren können.

Sollten sich die Konfigurationen der Schnittstellen unterscheiden, können Sie
den folgenden Workaround verwenden da das betroffene Join-Script die
Variablen lediglich zur Berechnung der DNS Reverse Zone und des Pointer
Records verwendet (bitte beachten Sie das dieser Workaround von uns nicht
getestet wurde):
[ul]
[li]Setzen Sie per univention-config-registry die Werte der
Variablen “interfaces/eth0/address” und “interfaces/eth0/netmask” gleich den
Werten aus “interfaces/eth2/address” und “interfaces/eth2/netmask”.[/li]
[li]Führen Sie den Join erneut aus.[/li]
[li]Entfernen Sie die Variablen “interfaces/eth0/address”
und “interfaces/eth0/netmask” anschließend um Netzwerkprobleme zu vermeiden.[/li][/ul]

Mit freundlichen Grüßen
Murat Odabas