Issues connecting to Windows Domain & Issues with App Center


#1

I cannot connect my Univention Corporate Server to my currently exisisting domain. I tried connecting during initial setup and it gave me the same error that it does if I try to connect after setup. I have two domain administration accounts that can join computers and controllers to the domain (Mine and the defualt administrator account in case mine gets locked out). I tried connecting using the administration account and it gives me the error incorrect username or password. I then try to connect using my personal account and it gives me the error “An Error has occoured, cannot process the request” and then it gives me the option to show the error message. I will paste it below:

Execution of command ‘adconnector/check_domain’ has failed:

Traceback (most recent call last):
File “/usr/lib/pymodules/python2.7/univention/management/console/base.py”, line 283, in execute
function(self, request)
File “/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py”, line 190, in _response
return function(self, request)
File “/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py”, line 318, in _response
result = _multi_response(self, request)
File “/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py”, line 462, in _response
return list(function(self, iterator, *nones))
File “/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py”, line 284, in _fake_func
yield function(self, *args)
File “/usr/lib/pymodules/python2.7/univention/management/console/modules/adconnector/init.py”, line 378, in check_domain
admember.check_ad_account(ad_domain_info, username, password)
File “/usr/lib/pymodules/python2.7/univention/lib/admember.py”, line 236, in check_ad_account
lo_ad.lo.sasl_interactive_bind_s("", auth)
File “/usr/lib/python2.7/dist-packages/ldap/ldapobject.py”, line 892, in sasl_interactive_bind_s
res = self._apply_method_s(SimpleLDAPObject.sasl_interactive_bind_s,*args,**kwargs)
File “/usr/lib/python2.7/dist-packages/ldap/ldapobject.py”, line 860, in _apply_method_s
return func(self,*args,**kwargs)
File “/usr/lib/python2.7/dist-packages/ldap/ldapobject.py”, line 236, in sasl_interactive_bind_s
return self._ldap_call(self._l.sasl_interactive_bind_s,who,auth,RequestControlTuples(serverctrls),RequestControlTuples(clientctrls),sasl_flags)
File “/usr/lib/python2.7/dist-packages/ldap/ldapobject.py”, line 106, in _ldap_call
result = func(*args,**kwargs)
LOCAL_ERROR: {‘info’: ‘SASL(-1): generic failure: GSSAPI Error: Miscellaneous failure (see text) (Matching credential (ldap/MY DOMAIN NAME AND DNS SERVER NAMES ARE HERE BUT I REMOVED THEM FOR SECURITY) not found)’, ‘desc’: ‘Local error’}

It then gives me the option to inform the vendor.

Also, when I try to use the App Center, it just sits there loading for a while and then gives me the error that the service docker.io is not running, I went into system services and there is no docker service there. I also tried to turn it on in the command line “service docker start” which it tells me to do so in the error and I get nothing. I went into package management and removed and tried to re-install the docker.io package and it will not let me re-install it now that I have removed it. It gives me the error “You cannot continue” with the message “This operation cuases problems in the following packages that cannot be resolved: docker.io

This is the fifth time I have started from scratch and set up this server if anybody can help me at all that would be great. I get the same errors every time I set up. This server is a virtual machine in Hyper-V.


#2

Hi,
It appears that this is related to [bug]38285[/bug]. Unfortunately I can not find a workaround from the comments.
You should contact Univention directly if you have a support contract.

Best Regards,
Dirk Ahrnke