Installation libqt3-mt-dev

german

#1

Hallo,
ich habe gestern die neue Version des Maintenance-Update installiert, beim Versuch,
libqt3-mt-dev zu installieren, erhalte ich folgende Fehlermeldung:

Thu May 24 16:52:48 2007 < < < < < < < <
install_libqt3-mt-dev

Thu May 24 16:52:48 2007 < < < < < < < <
Reading Package Lists…
Building Dependency Tree…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt3-mt-dev: Depends: libxext-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libxrandr-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libsm-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libxmu-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libice-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libx11-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libxt-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
Depends: libxrender-dev but it is not going to be installed
Depends: libxcursor-dev but it is not going to be installed
Depends: libxinerama-dev but it is not going to be installed
Depends: libxi-dev but it is not going to be installed
Depends: libxft-dev but it is not going to be installed
Depends: libgl1-mesa-dev but it is not installable or
libgl-dev
Depends: libglu1-mesa-dev but it is not installable or
libglu-dev

Können die benötigten Pakete bereitgestellt werden?

Gruß
Dietmar


#2

Hallo,

[quote=“dietmar”]The following packages have unmet dependencies:
libqt3-mt-dev: Depends: libxext-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
[…]
Depends: libglu1-mesa-dev but it is not installable or libglu-dev

Können die benötigten Pakete bereitgestellt werden?[/quote]
Es sind eigentlich alle zur Installation von libqt3-mt-dev erforderlichen Pakete auf apt.univention.de/addons/1.3/desktop/) mit in /etc/apt/sources.list aufgenommen werden.

Mit freundlichen Grüßen,

Wolf Wiegand


#3

Hallo,
das Problem ergibt sich aus den teils neueren Versionen auf der Maintenance-Update DVD,
z.B.

The following packages have unmet dependencies:
libxext-dev: Depends: libxext6 (= 6.8.2.dfsg.1-7.39.200611270801) but 6.8.2.dfsg.1-7.41.200705071630 is to be installed

Die dadurch benötigten Pakete sind aber nicht verfügbar (weder unter Desktop, noch devel etc.)

Gruß
Dietmar


#4

Hallo,

[quote=“dietmar”]The following packages have unmet dependencies:
libxext-dev: Depends: libxext6 (= 6.8.2.dfsg.1-7.39.200611270801) but 6.8.2.dfsg.1-7.41.200705071630 is to be installed[/quote]
unter apt.univention.de/addons/1.3/devel/ sind jetzt libxext-dev sowie alle weiteren Pakete aus dem dazugehörigen Quellpaket in der passenden Version verfügbar.

Mit freundlichen Grüßen,

Wolf Wiegand


#5

Vielen Dank.

Gruß
Dietmar