HTTP 500 Internal Server Error

Hi Community,

ich weiß nicht ob dass ein Kopano- od. Univentionproblem ist aber wenn ich in der Webapp bzw. Deskapp von Kopano ein SMB-Laufwerk verbinden möchte bekomme ich obigen Fehler. In der Log-Datei vom Apacheserver steht folgendes: PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 134217736 bytes) in /usr/share/kopano-webapp/plugins/filesbackendSMB/php/lib/SMB/src/Connection.php on line 43. Das selbe geschieht auch wenn ich ein S/MIME-Zertifikat hochladen möchte. Vielen Dank für eure Hilfe!

lg Ari

Hi, Community,

I don` t know if that is a Kopano or Univentionproblem but if I want to connect in the Webapp or Deskapp of Kopano a SMB drive I get the above error. In the log file of the Apacheerver I see following: Allowed memory size of 268435456 bytes exhausted (tried to allocate 134217736 bytes) in /usr/share/kopano-webapp/plugins/filesbackendSMB/php/lib/SMB/src/Connection.php on line 43. The same happens even if I want to upload an S / MIME certificate. Many thanks for your help!

greetings, Ari

Hello @ari1105p,

the same “Allowed memory size of… bytes exhausted” also happens for smime?

The easy way would be to increase the max memory in php.

Hello @fbartels,

thank you for your committment even on weekend! I increased the memory on 512M but unfortunately the same. I have no idea why.

Unfortunately I can´t upload the log-file. Even here i get a Error 500. :slight_smile:

did you also change the value in the right place (e.g. is the higher limit already recognized in the error message)?

If you cannot upload it here, then there are plenty pastebin services where you could upload your logs.

I changed it in /etc/php/7.0/apache2/php.ini memory_limit = 512M and in UCR php/memory/limit 512

Hope this works: here´s again

I’d recommend raising it until the error goes away.

To repeat my question from before: is it the same memory exhausted error in smime?

Are you trying to upload a large file in the files plugin?

Ok, I will try this. After I raised the value to 512M the S/Mime-Problem was gone. With 512M I can´t upload a file or connect with a samba-share. But ok I will try!

I changed the value until 4096M(I have only 8GB RAM) but unfortunately I get the same result. When I try to connect to a Samba-share the site load and load more than 2 minutes until the same error comes. When I connect with a Nextcloud-share there occurs no problems.

That sounds strange. Maybe the smb mobule is leaking memory? Could you post your question again to, then I’ll have someone from our WebApp qa look into this.

Or even better: if you have a subscription open up a support case so it gets the proper priority to have it reproduced.

I already post there: Poster “externa1” seems to have the same problem. I will open a support case even for my second problem the kopano-archive Server. I opened the support case at univention, my mistake. They said that´s a Kopano Problem.

Support case is open.

Any news? I opened a support case at Kopano but nothing happens.

I’d recommend to bump the support case.

1 Like

The solution in my case was to install php-smbclient_0.8.0-3_amd64.deb manually from the main-Repo of Debian 9. When I tried to install it with apt install or univention-install it came another version of php-smbclient. Don´t know why but it works now. Many thanks to the Kopano support!

Thanks for sharing the solution. php-smbclient 0.8.0-3 is also available in the unmaintained part of the UCS repository.