Fuse: failed to open /dev/fuse: Operation not permitted

docker

#1

Hello,
I installed curlftpfs in a container that is running CentOS 6.9. When I try to mount an FTP host I receive this error:
fuse: failed to open /dev/fuse: Operation not permitted
I read in a Docker forum a few things about it where adding the following to the container connection would help:
–privileged --device=/dev/fuse
They do this with the command “docker run” but I don’t know how to use this with the “univention-app” command.

I basically need to get into my app’s shell and I have tried stuff like this:
univention-app shell -it filewave --privileged --device /dev/fuse
but this returns an rcp error:
rpc error: code = 2 desc = containerd: container not started

Any help will be appreciated.
Thank you,
Mauricio.


#2

Hi,

univention-app is not a tool to do arbitrary docker management. It manages Apps from the Univention App Center the way they are published. Customization via univention-app is very limited.

You may want to

ucr set appcenter/apps/filewave/docker/params="--privileged --device /dev/fuse"
univention-app install filewave
univention-app shell filewave

Maybe this helps?

Kind regards,
Dirk Wiesenthal


#3

Thank you very much Dirk, I will definitively try this and I hope it works.
I will post the results later.


#4

I am getting a different error when trying to mount the FTP host within the container.

fusermount: mount failed: Operation not permitted

Is it possible to install and use curlftpfs on the Univention host itself? most of the files I need to transfer can be accessed from the host so mounting the FTP drive there will work for me too.
I tried downloading and installing the DEB package but I could not get it to install.