Fetchmail verhindert Upgrade von OX AppSuite 7.2 auf 7.4

german

#1

Hallo allerseits,

wir haben gestern versucht auf unseren UCS 3.1-1 das Upgrade auf die OX Appsuite 7.4 einzuspielen. Das Update wird zwar im Appcenter angezeigt, jedoch wird vom Paket

fetchmail

blockiert, das zuerst deinstalliert werden soll. Allerdings führt das Entfernen von fetchmail dazu, das die komplette Appsuite entfernt werden soll. Das wollen wir natürlich nicht. In unserer Umgebung wird fetchmail auch gar nicht benötigt. Offenbar stimmt da etwas mit den Abhängigkeiten nicht, oder?

viele Grüße

Sebastian

7.2.2-Rev25 auf Univention Corporate Server 3.1.1


#2

Hallo,

ein generelles Problem bezüglich der Abhängigkeiten kann ich im Moment nicht bestätigen. Bei mir lief dieses Update gerade problemlos durch.

OX, genauer das Paket univention-mail-postfix-ox, hat eine Abhängigkeit zu fetchmail, auch wenn Sie es in Ihrer konkreten Anwendung vielleicht nicht benötigen.

Es wäre nun zu prüfen, warum in Ihrer Umgebung fetchmail deinstalliert werden soll. Ansatzpunkte könnten sich in /var/log/univention/updater.log und/oder /var/log/apt/term.log finden.

Ebenfalls empfehenswert ist die Prüfung des Paketstatus mit “dpkg -C”

Viele Grüße,
Dirk Ahrnke


#3

Hallo Herr Arnke,

dpkg -C

gibt gar nichts aus, woraus ich schließe das fetchmail auch ordnungsgemäß installiert ist. Updater.log und term.log schweigen sich zu dem Thema aus. Vermutlich weil dort nur dokumentiert wird, wenn tatsächlich etwas am Paketstatus verändert wird. Ich vermute das liegt daran, das ich Installtionsvorgang im Appcenter nicht anstoßen kann.

Die genaue Meldung im appcenter lautet:

=snip==================================

Hersteller Open-Xchange GmbH
Kontakt info@open-xchange.com
Webpräsenz Open-Xchange App Suite
Installierte Version 7.2.1

Verfügbare Version 7.4.0-1
Aktualisierung nicht möglich Diese Applikation kann nicht gemeinsam mit den folgenden Applikationen oder Paketen installiert werden. Deinstallieren Sie diese zuerst.

Fetchmail

=snip==================================
viele Grüße


#4

Hallo,

können Sie bitte mal die Ausgabe von “aptitude search fetchmail” und “dpkg -l fetchmail” posten?

Viele Grüße,
Dirk Ahrnke


#5

Nachtrag:
“Fetchmail” in dieser Schreibweise und im Kontext des App Center meint höchstwahrscheinlich die App “Fetchmail”. Diese kollidiert in der Tat mit den Abhängigkeiten von OX.


#6

Hallo nochmals,
anbei die Ausgaben:

aptitude search fetchmail i A fetchmail - SSL enabled POP3, APOP, IMAP mail gatherer/forwarder v fetchmail-ssl - p univention-fetchmail - UCS fetchmail integration for UDM i univention-fetchmail-schema - UCS schema package for univention-fetchmail

und

dpkg -l fetchmail Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten | Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/ Halb installiert/Trigger erWartet/Trigger anhängig |/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht) ||/ Name Version Beschreibung +++-========================-========================-================================================================ ii fetchmail 6.3.18-2.34.201304111417 SSL enabled POP3, APOP, IMAP mail gatherer/forwarder

Offenbar ist das Paket installiert (warum auch immer). Die App “Fetchmail” ist nicht installiert.

Viele Grüße


#7

Mir fällt hierzu etwas auf:

[quote]i A fetchmail - SSL enabled POP3, APOP, IMAP mail gatherer/forwarder
v fetchmail-ssl -
p univention-fetchmail - UCS fetchmail integration for UDM
i univention-fetchmail-schema - UCS schema package for univention-fetchmail[/quote]

das ‘i’ bei univention-fetchmail-schema sagt mir: daß univention-fetchmail irgendwo installiert oder installiert gewesen sein muß, entweder auf diesem Host oder einem anderen in der Domain. Dann könnte univention-fetchmail-schema das Problem sein.


#8

Ah, ok. Die Frage ist nur, was passiert mit der Replikation, wenn ich diese fetchmal-schema Paket deinstalliere? Wahrscheinlich müsste ich auf allen Systemen prüfen, ob das fetchmail-schema installiert ist. Wenn ja sollte es deinstalliert werden, richtig?

viele Grüße

Sebastian


#9

Hallo nochmals,

es hat genügt, das fetchmail-schema paket vom ox server zu entfernen. Danach klappte das Upgrade problemlos.

Vielen Dank für die hilfreichen Hinweise.

Sebastian