Feature request - Allow newer version join older version


#1

It seems very odd to me that I can’t join 4.3 to 4.1_5.

Is this true for all backwards joins?
Typically major upgrades aren’t done on live servers. It’s best practice
to create a new domain controller, join it to the domain, the transfer FSMO roles, then
decommission the old server. It seems this “best practice” is not possible with UCS.

Are there any newer versions that can join older versions? Am I trying to skip too many
major versions? Is there a way to force the join or bypass the version check?

4.1_5 is too old to run the upgrade in place, and I can’t join 4.3 to it.
Seems like I’m between a rock and a hard place.


#2

Hey,

Univention doesn’t support the master having a lower version than any other machine. In each release notes you’ll find a note that the master must always be updated first. I don’t think that this will ever change. You should really just upgrade from your current version. If you want to install a new machine and cannot find an older ISO image to download: get them from here.

I really don’t understand what you’re trying to say here. What’s your actual issue with upgrading?

What you’ve described and what you’d use on Windows-based AD DCs will indeed not work with UCS servers. For UCS you usually just create a VM snapshot of all servers, upgrade them and remove the snapshots once tests show that the update went well.

Kind regards,
mosu