Etherpad zeigt keine available plugins/Konfiguration an

german

#1

Hallo,

ich habe gerade die aktuelle Version von Etherpad aus dem AppCenter geladen. Beim Aufruf der Adminseite kann ich mir zwar im Bereich Troubleshooting die installierten Plugins anschauen, nicht jedoch die möglichen weiteren Plugions im “Plugin Manager”. Dort kommt immer nur “Fetching…” Wir befinden uns hier hinter einem Proxy. “http_proxy” ist gesetzt.

root@ucsapp:/opt/etherpad-lite# less var/etherpad.log Ensure that all dependencies are up to date... If this is the first time you have run Etherpad please be patient. npm WARN package.json async-stacktrace@0.0.2 No repository field. npm WARN package.json channels@0.0.4 No repository field. npm WARN package.json tinycon@0.0.1 No repository field. Ensure jQuery is downloaded and up to date... Clearing minified cache... Ensure custom css/js files are created... Started Etherpad... ESC[32m[2015-10-14 12:05:39.092] [INFO] console - ESC[39mInstalled plugins: ep_etherpad-lite [2015-10-14 12:05:39.092] [INFO] console - Installed plugins: ep_etherpad-lite ESC[32m[2015-10-14 12:05:39.128] [INFO] console - ESC[39mReport bugs at https://github.com/ether/etherpad-lite/issues [2015-10-14 12:05:39.128] [INFO] console - Report bugs at https://github.com/ether/etherpad-lite/issues ESC[33m[2015-10-14 12:05:39.129] [WARN] console - ESC[39mCan't get git version for server header ENOENT, no such file or directory '/opt/etherpad-lite/.git/HEAD' ESC[33m[2015-10-14 12:05:39.130] [WARN] console - ESC[39mCan't get git version for server header ENOENT, no such file or directory '/opt/etherpad-lite/.git/HEAD' ESC[32m[2015-10-14 12:05:39.131] [INFO] console - ESC[39mYour Etherpad version is 1.5.6 () ESC[32m[2015-10-14 12:05:39.297] [INFO] console - ESC[39mYou can access your Etherpad instance at http://127.0.0.1:9001/ ESC[32m[2015-10-14 12:05:39.297] [INFO] console - ESC[39mThe plugin admin page is at http://127.0.0.1:9001/admin/plugins [2015-10-14 12:05:39.129] [WARN] console - Can't get git version for server header ENOENT, no such file or directory '/opt/etherpad-lite/.git/HEAD' [2015-10-14 12:05:39.130] [WARN] console - Can't get git version for server header ENOENT, no such file or directory '/opt/etherpad-lite/.git/HEAD' [2015-10-14 12:05:39.131] [INFO] console - Your Etherpad version is 1.5.6 () [2015-10-14 12:05:39.297] [INFO] console - You can access your Etherpad instance at http://127.0.0.1:9001/ [2015-10-14 12:05:39.297] [INFO] console - The plugin admin page is at http://127.0.0.1:9001/admin/plugins ESC[32m[2015-10-14 12:16:10.436] [INFO] ueberDB - ESC[39mFlushed 1 values [2015-10-14 12:16:10.436] [INFO] ueberDB - Flushed 1 values ESC[32m[2015-10-14 12:16:10.573] [INFO] ueberDB - ESC[39mFlushed 1 values [2015-10-14 12:16:10.573] [INFO] ueberDB - Flushed 1 values ESC[32m[2015-10-14 12:16:10.678] [INFO] ueberDB - ESC[39mFlushed 1 values [2015-10-14 12:16:10.678] [INFO] ueberDB - Flushed 1 values ESC[32m[2015-10-14 12:16:22.947] [INFO] ueberDB - ESC[39mFlushed 1 values
Auch erscheint beim Klicken auf “Settings” nicht due aktuelle Konfiguration.

Die Installation von weiteren Plugins über die Kommandozeile

npm install ep_header_and_footer ep_headings2 ep_subscript_and_superscript ep_themes

lässt Etherpad zwar ohne weitere Fehlermeldung starten - Port 9001 wird aber nicht verbunden.

Was ist da falsch?

Viele Grüße
Stephan Hendl


#2

Hallo Herr Hendl,

über jjasonclark.com/how-to-setup-nod … web-proxy/ , vielleicht hilft das weiter?

Mit freundlichen Grüßen,
Arvid Requate


#3

Hallo Herr Requate,

vielen Dank! Leider gibt es keine Verbesserungen. Offensichtlich werden bei neueren “npm”-Versionen die Environmentvariablen gezogen; jedenfalls konnte ich einige Plugins installieren - wenn sie auch nicht wirklich funktionierten… Die Fehler im Log sind noch immer da und auch beim Aufruf des “Plugin Managers” kommt immer noch “Fetching…”.

Viele Grüße
Stephan Hendl