Ethernet Netzwerkadapter synchronisiert falschen Speed

german

#1

Hallo zusammen,

ich nutze UCS als Heimserver. Dieser ist über Gigabit Ethernet an den Router angebunden.

Ohne Änderung an der Konfiguration besteht seit heute morgen (nachts ist der Server ausgeschaltet) jedoch nur noch eine 10 Mbits Verbindung. Das Kabel als auch den Port am Router habe ich bereits auf Hardwaredefekte überprüft.

Eine Überprüfung meines adapters (eth1) mit mii-tool (ethool paket ist nicht per default installiert) lieferte folgendes:

root@server:~# mii-tool -v eth1 SIOCGMIIREG on eth1 failed: Input/output error SIOCGMIIREG on eth1 failed: Input/output error eth1: negotiated 100baseT-FD flow-control, link ok product info: vendor 00:50:43, model 11 rev 1 basic mode: autonegotiation enabled basic status: autonegotiation complete, link ok capabilities: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control link partner: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

Löse ich eine neue autonegotion aus wird nach einiger Zeit wieder eine Gigabit Verbindung hergestellt.

root@server:~# mii-tool -r eth1 [...] root@server:~# mii-tool -v eth1 SIOCGMIIREG on eth1 failed: Input/output error SIOCGMIIREG on eth1 failed: Input/output error eth1: negotiated 1000baseT-FD flow-control, link ok product info: vendor 00:50:43, model 11 rev 1 basic mode: autonegotiation enabled basic status: autonegotiation complete, link ok capabilities: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD advertising: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control link partner: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

Nach einem Reboot besteht das gleiche Problem jedoch wieder. Gibt es eine Möglichkeit dieses Problem dauerhaft zu lösen?

An dieser Stelle sei auch noch bezüglich der Hardware erwähnt, dass es sich um einen ThinksServer TS430 0441 handelt. Ist der Server im Standby - besteht also Netzspannung - ist das ThinkServer Management Module aktiviert. Dieses stellt dabei zunächst eine 10 Mbits Verbindung ins Netzwerk her. Wird jedoch das OS gebootet, so ist der Netzwerkadapter bisher jedoch immer automatisch in den Gigabit Modus gewechselt.

Vielen Dank und mit freudlichen Grüßen

nycbroker


#2

Moin,

Die Geschwindigkeitsaushandlung ist ja etwas, das die beteiligte Hardware (Netzwerkchips auf im Server und dem Switch) anhand der gemessenen elektrischen Gegebenheiten durchführen. Softwareseitig kann man das zwar wieder anstoßen, aber auch nur begrenzt beeinflussen.

Was Sie probieren könnten, ist die Ports beidseitig fest auf 1000 full duplex zu stellen. Wichtig, dass Sie das sowohl auf dem Server als auch auf dem Switch machen. Ich vermute aber, dass wenn Sie mit der Auto-Nego schon Probleme bekommen, dann mit fester Einstellung ebenfalls Probleme bekommen werden, und die sehen dann vermutlich so aus, dass in dem Moment gar keine Kommunikation mehr möglich ist.

Weiterhin ausprobieren: Hardware tauschen, also Kabel, Switch, Netzwerkkarte/-port sofern möglich.

Gruß,
mosu