Error during upgrade from 4.4 to 5.0.2

During the pre-update script, I have the error :

The system can not be updated to UCS 5.0 due to the following reasons:

python_ucr_template_compatibility:
The following UCR templates are not compatible with Python 3:
         /etc/univention/templates/files/etc/ldap/slapd.conf.d/11univention-ldap-usercert_schema (package: univention-ldap-usercert)
See <https://help.univention.com/t/17948> for information on how to proceed with each template.

old_packages:
WARNING: The following packages from UCS-4 are still installed, which are no longer supported with UCS-5:
        univention-kdm
        univention-x-core
        univention-dansguardian

Use "univention-remove --purge" with the packages as following arguments to remove them

minimum_ucs_version_of_all_systems_in_domain:
The following extensions are incompatible with UCS 5.0:
        cn=univention-openvpn,cn=udm_hook,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=univention-openvpn-schema,cn=udm_syntax,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=63openvpn-sitetosite,cn=ldapacl,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=WindowsCertificateHook,cn=udm_hook,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=SimpleAuthCertificateHook,cn=udm_hook,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=guacamole,cn=udm_syntax,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)
        cn=guacamole/config,cn=udm_module,cn=univention,dc=dmp,dc=intranet: [unspecified..unspecified)

Error: Update aborted by pre-update script of release 5.0-0

Can I safely remove the univention-kdm, univention-x-core, univention-dansguardian (I have squid installed) ?
and for the extension, openvpn, guacamole have been remove for more than 1 year on the server

Vincent

Can I also remove all the cool-solution packages

univention-ldap-usercert | 4.2.0-7A~4.4.0.202205202007 | updates.software-univention.de cool-solutions/all/ Packages
univention-ldap-usercert | 4.2.0-5A~4.3.0.201902271634 | updates.software-univention.de cool-solutions/all/ Packages
univention-ldap-usercert | 4.0.7-0A~4.2.0.201705121238 | updates.software-univention.de cool-solutions/all/ Packages
univention-ldap-usercert | 4.0.6-3.42.201607281559 | updates.software-univention.de cool-solutions/all/ Packages
univention-ldap-usercert | 4.0.6-1.40.201605041518 | updates.software-univention.de cool-solutions/all/ Packages
univention-pam | 8.1.0-1.260.201510161300 | updates.software-univention.de cool-solutions/all/ Packages
univention-usercert | 4.2.0-7A~4.4.0.202205202007 | updates.software-univention.de cool-solutions/all/ Packages
univention-usercert | 4.2.0-5A~4.3.0.201902271634 | updates.software-univention.de cool-solutions/all/ Packages
univention-usercert | 4.0.7-0A~4.2.0.201705121238 | updates.software-univention.de cool-solutions/all/ Packages
univention-usercert | 4.0.6-3.42.201607281559 | updates.software-univention.de cool-solutions/all/ Packages
univention-usercert | 4.0.6-1.40.201605041518 | updates.software-univention.de cool-solutions/all/ Packages
univention-windowscert | 4.2.0-7A~4.4.0.202205202007 | updates.software-univention.de cool-solutions/all/ Packages
univention-windowscert | 4.2.0-5A~4.3.0.201902271634 | updates.software-univention.de cool-solutions/all/ Packages
univention-windowscert | 4.0.7-0A~4.2.0.201705121238 | updates.software-univention.de cool-solutions/all/ Packages
univention-windowscert | 4.0.6-3.42.201607281559 | updates.software-univention.de cool-solutions/all/ Packages
univention-windowscert | 4.0.6-1.40.201605041518 | updates.software-univention.de cool-solutions/all/ Packages

Vincent

can somone help me for this error ?