Error by updating UCS from 4.2.5 to 4.3.0

I have following errors by updatin from 4.2.5 to 4.3.0:

03.11.19 11:19:57.349 DEBUG_INIT
**** Starting univention-updater with parameter=[’/usr/share/univention-updater/univention-updater’, ‘net’, ‘–updateto’, ‘4.3-0’, ‘–ignoressh’, ‘–ignoreterm’]
Version=4.2
Patchlevel=5
starting net mode
—>DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 4.3-0
**** Downloading scripts at Sun Nov 3 11:19:59 2019
**** Starting actual update at Sun Nov 3 11:20:02 2019
Running preup.sh script
So 3. Nov 11:20:02 CET 2019

HINT:
Please check the release notes carefully BEFORE updating to UCS 4.3-0:
English version: https://docs.software-univention.de/release-notes-4.3-0-en.html
German version: https://docs.software-univention.de/release-notes-4.3-0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
dpkg: Warnung: Die Anforderung, univention-config-wrapper zu entfernen, wird ignoriert; es ist nicht installiert
Checking for space on /var/cache/apt/archives: OK
Checking for space on /boot: OK
Checking for space on /: OK
Checking for package status: iU ldap-utils 2.4.45+dfsg-1~bpo9+1A~4.3.0.201801091316 amd64 OpenLDAP utilities
failed
ERROR: The package state on this system is inconsistent.
Please run ‘dpkg --configure -a’ manually
Error: Update aborted by pre-update script of release 4.3-0

And in a SSH session after “dpkg --configure -a”:

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von ldap-utils:
ldap-utils hängt ab von libldap-2.4-2 (= 2.4.45+dfsg-1~bpo9+1A~4.3.0.201801091316); aber:
Version von libldap-2.4-2:amd64 auf dem System ist 2.4.42+dfsg-2.A~4.2.0.201707261131.

dpkg: Fehler beim Bearbeiten des Paketes ldap-utils (–configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
ldap-utils

Can you help me please?
Best regards!!

Hi @nostromox,

you don’t have the unmaintained repository enabled, right?

Actually, we’ve also had some issues, upgrading from 4.2-5. Deactivating the 4.2-5 components solved the issues for us:

ucr set repository/online/component/4.2-5-errata=disabled​

Cheers

Sebastian

Sorry, still the same errors after trying to update to 4.3.0 via Web console. I need to reboot the Server?
repository/online/component/4.2-5-errata is disabled now when i look into the Registry.

Thank you!

No ideas? Can i resolve the issue by installing this package manually with dpkg -i?

Push please, can you help? :-/