DNS Zone, forward only definieren

german

#1

Guten Tag

Ich habe die Situation, dass ich generall einen 2 DNS-Server als Forwarder über UCR definiert habe dns/forwarder1 bzw. dns/forwarder2

Nun bräuchte ich noch für 2-3 Zonen einen forward-Zone zu definieren, damit im Unternehmensnetz auch durch den UCS-Master und dessen DNS-Client 2-3 spezielle Zonen auflösbar werden, die von einem anderen Nameserver, als die Standard-Forwarder vorgehalten werden (und der auch nicht ein Cacher ist, wäre ja praktisch)

Auf einem “normalen” Debian machte ich die forwarder über named.conf.options

[code]
options {
[…]

forwarder {


};

};[/code]

Und eine Zone, die es zu speziell zu forwarden gilt, würde in named.conf.local sein, und als Zone vom Typ forward angegeben mit den entsprechenden Forwarders. (ich hätte bind9/local.conf in UCS gesehen, funktioniert aber so leider nicht.

Bei UCS finde ich (und das erscheint mir etwas komisch) dass dieser globale Forwarder nicht im Kontext options {}; sondern eine Zone “.” definiert ist, vom Typ forward, wo Anfragen dann an die beiden Forwarder geleitet werden.

Gibt es einen korrekten Weg solche “ge-forwardete” Zonen in UCS einzutragen?


#2

Hallo,

[quote=“msi”]
Bei UCS finde ich (und das erscheint mir etwas komisch) dass dieser globale Forwarder nicht im Kontext options {}; sondern eine Zone “.” definiert ist, vom Typ forward, wo Anfragen dann an die beiden Forwarder geleitet werden.[/quote]
Aus meiner Sicht ist das nur ein anderer, etwas konsistenterer Weg als das Setzen des Forwarders in den Optionen. Damit wird für die Root-Zone ein Forwarder gesetzt.
Für zusätzliche Zonen macht man das dann analog.

Derzeit noch nicht über UMC/UDM. Sie können das aber in die jeweilige lokale Konfiguration eintragen. Welche das ist, hängt vom gesetzten DNS-Backend ab.

root@master:/etc/bind# ucr get dns/backend samba4
Die lokale Konfiguration ist dann in /etc/bind/local.conf.samba4, ansonsten /etc/bind/local.conf.
Der Rest ist dann etwas wie:

[code]root@master:/etc/bind# cat local.conf.samba4

add local zones here

zone “domain.tld” {
type forward;
forwarders {
1.2.3.4;
};
};
[/code]

Viele Grüße,
Dirk Ahrnke


#3

Der Enhancement-Bug dazu ist forge.univention.org/bugzilla/s … i?id=17668


#4

Herzlichen Dank (ich hatte es gerade nicht auf der obersten stellte in meiner Prio-Liste)

Aber genau: Da es ein UCS@School mit Samba 4 ist, wird Samba 4 als Backend genommen, ergo wurden die Forward-Zonen in local.conf
gar nicht erst ausgewertet. In local.conf.samba4 hingegen problemlos. Besten Dank!