Directory-Listener Problem


#1

Hi @all,

I have a seperate UCS instance running kopano4ucs.
On this member server I’m facing the issue that the univention-directory-listener service always fails to start since last errata update (currently running 4.2-3 errata305).

If I start the service via systemd it starts as expected and it seems to be fine.
I’ve already set debug level to 4 but only entry in log on reboot is:
LISTENER ( WARN ) : received signal 15

Any suggestions?


#2

Hey,

I’m not sure I understand the problem. You’re saying that starting the listener manually works? Therefore I assume that it just fails to start during the boot sequence?

Please post the journal content for the corresponding service unit for the current boot: journalctl -b -u univention-directory-listener.service

Kind regards,
mosu


#3

Have had also problems like this after the latest upgrade. And the LDAP-Sync does not work on the Kopano server

I had to force a re-join of the Kopano Server in the UMC for this. After the succesfully re-join all was running proper and also the broken LDAP-Sync from the UCS-Master to the Kopano-Backup works as expected


#4

@Moritz_Bunkus,
yes during boot sequence the directory listener always fails to start.
Here are the log entries:

Feb 24 13:27:08 kopanosrv systemd[1]: Starting LSB: Univention Directory Listener Daemon…
Feb 24 13:27:08 kopanosrv univention-directory-listener[983]: Starting Univention Directory Listener Daemon: univention-directory-listener failed!
Feb 24 13:27:08 kopanosrv systemd[1]: univention-directory-listener.service: control process exited, code=exited status=1
Feb 24 13:27:08 kopanosrv systemd[1]: Failed to start LSB: Univention Directory Listener Daemon.
Feb 24 13:27:08 kopanosrv systemd[1]: Unit univention-directory-listener.service entered failed state.

I also tried to rejoin the server but problem still the same.