DHCP: Kein Gateway für Android-Geräte

german

#1

Hallo,

ich habe hier eine Merkwürdigkeit mit einem frischen UCS-Setup: Alle möglichen Geräte (PCs, Drucker, IOS-Geräte) bekommen ordentlich ihr Netzwerksetup per DHCP. Nur bei Android-Geräte bleibt das Gateway auf der Strecke. IP, DNS, alles wird sauber gesetzt nur das Gateway nicht. Ich habe so etwas noch nie bei einem DHCP-Server erlebt. Hat jemand eine Idee wie sich das beheben lässt?

TIA
Matthias


#2

Hallo,

liegen die Androiden ggf. in einem anderen DHCP-Subnet als die Geräte, bei denen ein Gateway konfigutiert wird?

Haben Sie eventuell Sonderkonfigurationen im DHCP wie z.B. mehrere Routen (routing fails when dhcp server sends more than 2 routing table entries)?

Viele Grüße,
Dirk Ahrnke


#3

Wenn’s eine Spezialität gäbe wäre ich ja froh … aber das ist alles so ganz und gar flacher Standard ohne irgend eine Besonderheit.


#4

Hmm, je mehr ich über das Thema Android und DHCP suche, desto mehr Problemberichte finde ich. Das Gehacke in den Foren und teilweise auch im Android-Bugtracker hat teilweise Sandkastenniveau, zumindest was das Zuschieben der Verantwortung betrifft.
Nun gut.

Was Sie erstmal machen können, ist die DHCP-Konfiguration gemäß [url]Keine Antwort von UCS an DHCP-Relay] unter die Lupe zu nehmen. Bei mehreren Ranges wäre da mit der IP-Adresse des Androiden abzugleichen.
Man sollte sich auch in /var/log/messages vergewissern, dass der DHCP-Request wirklich über diesen Server gegangen ist.

Ansonsten fällt mir dann nur noch die große Keule ein. Also mit Wireshark die DHCP Pakete mitschneiden und nachsehen, ob der Client höflich und korrekt gefragt und auch eine korrekte Antwort bekommen hat.

Viele Grüße,
Dirk Ahrnke