Dateisystemquota über Richtlinie greift nicht

german

#1

Hallo,

ich möchte das Home-Verzeichnis aller Benutzer mit einem Dateisystemquota belegen. Zunächst habe ich Benutzer-Modul auf dem /home- Verzeichnis das Quota aktiviert. Hier heraus kann ich die Benutzer einzeln auch mit dem Quota belegen und das funktioniert auch. Da ich aber nicht das quota für alle Benutzer von Hand erstellen möchte, habe ich eine Richlinie vom Typ Benutzer-Quota im Richlinien-Modul erstellt. Müßte diese Richtlinie jetzt nicht füe alle Benutzer gelten?
Wen ich einen Benutzer neu anmelde, dann greift das qouta nicht.

MfG H. Rehberg


#2

Hallo Herr Rehberg,

eine Benutzer Quota Richtlinie muss mit einem Share verknüpft werden, damit Sie aktiv wird (für die Partition “hinter” dem Share). Für die “home”-Freigabe ist das nicht so einfach.
Die “homes” Freigabe (UCR samba/share/home=yes) erhält ihre spezielle Funktionsweise nur durch den Namen “homes”. Ich denke daher es ist am einfachsten wenn Sie UCR samba/share/home=no setzen und in der UMC eine Freigabe “homes” auf dem Server, mit den gleichen Einstellungen, erzeugen. An dieses Objekte können Sie die Quota-Richtlinie dann binden.
Da Quota partitionsweise funktioniert reicht es aber ggfs. schon aus, einen beliebigen NFS und/oder Samba Share auf der Home-Partitionen anzulegen (für ein beliebiges Unterverzeichnis meine ich) an den Sie dann die Richtlinie binden können.

Mit freundlichen Grüßen,
Tim Petersen


#3

EIn kurzer Nachtrag hierzu: In aktuellen Versionen sollten Sie den Share normal in der UMC administrieren können - haben Sie dort die Richtlinie entsprechend verknüpft?
Sollte dennoch keine Auswertung stattfinden können Sie mit quota/logfile zu Analysezwecken eine Logdatei zur Protokollierung angeben.


#4

Hallo Herr Petersen,

ich habe jetzt mal ein neues share auf der Partition angelegt. (share: “info” Pfad: “/home/shares/info” , im Container “efeld.schule:/SchulzentrumEringerfeld/shares”).
Jetzt habe ich unter Richtlinien den Eintrag “Benutzer-Quota”, Richtlinien-Konfigiration “Ererbt”.
(Leider bin ich mit dem Richtlinienkonzept noch nicht ganz vertraut und aus der Handbuch werde ich hier auch noch nicht ganz schlau.)
Wie kann ich jetzt die Richtlinen verknüpfen? Im UMC (UCS4.0) kann ich jetzt eine Rchtlinie anlegen, das habe ich auf getan (Soft-Limit: 900, Had-Limit: 1000). Ergebnis:

Quota für die Share “info” greift nicht.
Muß die Variable “user/quotadefault” auf “yes” gesetzt werden? (Bei “no” gibt es keinen log, bei “yes” erhalte ich folgendes Quota Logfile: -------------------------------------------------------- start Wed Feb 04 08:48:56 CET 2015 Set quota for user demirha2.gy Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u demirha2.gy 0 0 0 0 /home -------------------------------------------------------- exit -------------------------------------------------------- start Wed Feb 04 08:49:42 CET 2015 Set quota for user demirha2.gy Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u demirha2.gy 0 0 0 0 /home -------------------------------------------------------- exit -------------------------------------------------------- start Wed Feb 04 08:49:44 CET 2015 Set quota for user TEST-PC$ Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u TEST-PC$ 0 0 0 0 /home -------------------------------------------------------- exit -------------------------------------------------------- start Wed Feb 04 08:49:49 CET 2015 Set quota for user demirha2.gy Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u demirha2.gy 0 0 0 0 /home -------------------------------------------------------- exit -------------------------------------------------------- start Wed Feb 04 08:50:01 CET 2015 Won't set quota for system-users (root has UID 0) -------------------------------------------------------- start
demirha2.gy war der User, den ich danach neu angemeldet habe. Wert “0” bedeutet doch sicher den Quotawert “Unbegrenzt” ??
Muß ich für die Gruppe des Users (“schueler-schulzentrumeringerfeld”) auch eine Richtlinie anlegen?

Mit freundlichen Grüßen
H. Rehberg


#5

Hallo Herr Rehberger,

Damit eine neu erstellte Richtlinie Auswirkungen hat, muss Sie mit einem passenden LDAP-Objekt verknüpft werden. In Ihrem Fall wäre das der Share “info”. Dort müssen Sie am Reiter Richtlinien den Eintrag Benutzer-Quota Richtlinien-Konfiguration von Ererbt auf die neue Richtline ändern.

root@system:~# ucr search quota/userdefault quota/userdefault: <empty> The quota settings defined in the UCS management system are evaluated and enabled during login to UCS systems by the tool univention-user-quota run in the PAM stack. If this variable is set to 'no', this evaluation is deactivated.

Steht die Variable auf “no” wird beim Durchlaufen des PAM-Stacks keine Neu-Auswertung der Quota-Einstellungen vorgenommen. Ich vermute Sie möchten:
a) diese Variable auf “yes” setzen
b) In der Richtlinie den Haken Einstellungen bei jedem Login anwenden setzen

Anschließend müsste eine Anmeldung eines Testbenutzers eigentlich zu einer Aktualisierung der Quota führen.

[quote=“HRehberg”]Wert “0” bedeutet doch sicher den Quotawert “Unbegrenzt” ??
Muß ich für die Gruppe des Users (“schueler-schulzentrumeringerfeld”) auch eine Richtlinie anlegen?
[/quote]

man setquota sagt:

setquota [ -rm ] [ -u | -g ] [ -F quotaformat ] name block-softlimit block-hardlimit inode-softlimit inode-hardlimit -a | filesystem...

Von daher sollte 0 “unlimited” sein, ja. Mit der Gruppe müssen Sie die Richtlinie nicht verknüpfen (s.o.).

Mit freundlichen Grüßen,
Tim Petersen


#6

Hallo,

Genau das habe ich getan, quotadefault steht auf yes. Die Freigabe “info” hat jetzt eine Richtlinie “Benutzer-Quota”
“cn=infoquota,cn=userquota,cn=shares,cn=policies,dc=schule,dc=efeld”
Soft-Limit: 900 Hard-Limit: 1000, “Einstellungen bei jedem Login anwenden” ist angehakt.

Trotzdem, kein Quota!

Quota wird gesetzt, aber mit Wert 0. Siehe unten: (quotalog:)

[code]-------------------------------------------------------- start
Thu Feb 05 15:04:00 CET 2015
Set quota for user TEST-PC$
Found 28 shares and 1 mountpoints
Set quota on mountpoint “/home”: /usr/sbin/setquota -u TEST-PC$ 0 0 0 0 /home
-------------------------------------------------------- exit

MfG
Heiko Rehberg
-------------------------------------------------------- start
Thu Feb 05 15:04:04 CET 2015
Set quota for user demirha2.gy
Found 28 shares and 1 mountpoints
Set quota on mountpoint “/home”: /usr/sbin/setquota -u demirha2.gy 0 0 0 0 /home
-------------------------------------------------------- exit[/code]



#7

Hallo,

Sie haben 900 und 1000 Byte konfiguriert (default laut tooltip) - ich schätze daher kommen die "0"en…
Testen Sie bitte noch einmal mit den Werten 900MB und 1000MB und prüfen danach folgendermaßen:

/usr/sbin/univention-user-quota Administrator repquota -va

Mit freundlichen Grüßen,
Tim Petersen


#8

Hallo Herr Petersen,

ich habe das Qouto umgestell auf 900MB (Softlimit) und 1000MB (Hardlimit). Immer noch das selbe, kein Quota.

-------------------------------------------------------- start Fri Feb 06 10:11:48 CET 2015 Set quota for user demirha2.gy Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u demirha2.gy 0 0 0 0 /home -------------------------------------------------------- exit -------------------------------------------------------- start Fri Feb 06 10:11:59 CET 2015 Set quota for user TEST-PC$ Found 28 shares and 1 mountpoints Set quota on mountpoint "/home": /usr/sbin/setquota -u TEST-PC$ 0 0 0 0 /home -------------------------------------------------------- exit

Gruß

Heiko Rehberg

P.S. Gerade fällt mir auf das die Überschrift des Themas falsch ist: Sollte heißen " Dateisystemquota über Richtlinie greift nicht" und nicht “Dateisystemquota über Freigabe greift nicht”
Kann man das noch ändern?


#9

Hallo Herr Rehberg,

ich kann das leider nicht nachvollziehen - unter Umständen wurde die Richtlinie bzw. die Richtlinienauswertung noch nicht aktualisiert?
Das kann händisch erfolgen (ansonsten stündlich per Cron):

/etc/init.d/univention-directory-policy start

Im LDAP können Sie die Werte auch noch einmal direkt an der Policy kontrollieren:

[code]
root@master:~# univention-ldapsearch cn=testquota

testquota, userquota, shares, policies, tim.ucs4

dn: cn=testquota,cn=userquota,cn=shares,cn=policies,dc=tim,dc=ucs4
cn: testquota
objectClass: top
objectClass: univentionPolicy
objectClass: univentionPolicyShareUserQuota
objectClass: univentionObject
univentionObjectType: policies/share_userquota
univentionQuotaReapplyEveryLogin: TRUE
univentionQuotaSoftLimitSpace: 100MB
univentionQuotaHardLimitSpace: 150MB[/code]

Kontrolle der Verknüpfung:

root@master:~# univention-ldapsearch cn=testfreigabe | grep PolicyReference objectClass: univentionPolicyReference univentionPolicyReference: cn=testquota,cn=userquota,cn=shares,cn=policies,dc=tim,dc=ucs4

Mit freundlichen Grüßen,
Tim Petersen