Changing timezone doesn't work, wrong zonefiles


I have a timezone problem on two different servers running UCS 4.1 and 4.2.
No mather, if I choose UTC or Europe/Berlin, my local time is always displayed in CEST.
I noticed, that the file /etc/localtime is not a symlink to /usr/share/zoneinfo/xxx but a copy of it.
Also I diffed /usr/share/zoneinfo/UTC and /usr/share/zoneinfo/Europe/Berlin and noticed, that those files were identically, which I think, they shouldn’t.

When I diff those files on an Ubuntu server, they are different.
Were can I get to correct zoneinfos, because the installed ones are nuts.
And why are those files wrong?

Hopefully I receive a note with hints to fix this issues very soon.
Thanks in advanced.


Problem solved, files fixed!

On a third system I was able to find the correct UTC-file and copied it to the other servers.
Now, everything with timezones works correct.
But it would be interesting to know, why Univention copied the timezone-file from /usr/share/zoneinfo/Europe/Berlin to /usr/share/zoneinfo/UTC instead of /etc/localtime.

Btw. creating a symlink would be a better choice.


I have to reopen this thread, because it seems to be a bug which needs to be solved.
Today I sent an appointment from Kopano to my brother and noticed a two hour timediff.

I rechecked the file /usr/share/zoneinfo/UTC and voila, it was a copy of /usr/share/zoneinfo/posix/Europe/Berlin, again.

Nothing should change those timezone-files within /usr/share/zoneinfo/ but Iit was overwritten the second time with invalid content.

Please check all your script timezone-changing-scripts, this is anoying.

Brgds, Christian.

Do you know at which time the file was copied? Do you see any hints in the logfiles?

Unfortunatelly not.
Date and time where preserved, so the changed UTC file had the same date information /usr/share/zoneinfo/posix/Europe/Berlin had.

I checked the logs for anything with UTC, but couldn’t find entries other than clock changes.

Kopano Calendar Invitations show up two hours before real date
Just were to early at a date!!!
Any help?

Check the files I mentioned before.

i dont get it. so what exactly do i have to do to get the combination ucs/kopano, sold as exchange your exchange, running with properly calendar!?

you need to check if the your configured timezone-file differs from UTC

Unfortunatelly, I need to snapshot the command line, because single high commas are used for formatation in this forum.

If the output says, the files differ, then we need to dig deeper, if they don’t differ, then you need to replace it with the correct UTC file from a different installation.

if you md5sum /usr/share/zoneinfo/UTC you should get this return:
c79354b8dbee09e62bbc3fb544853283 /usr/share/zoneinfo/UTC

it is


can you provide the correct file for me plz?

thank you very much!

here you are:

I have to thank you a 1000 times
all three new installations had the same problem
i was too early yestarday and had to wait for 2h
the file is working!

i am escalating at ucs/kopano at the moment to get a fix to the repository!

1 Like

Hi, great to hear that it works for you now. We could not reproduce this issue internally. You said that your new installations all have the issue of the wrong timezone file. Could you give us detailed information how you installed the UCS system?

  • Installation medium (DVD, virtual Appliance, …)
  • Which packages and apps were installed
  • Locale / Country / Date settings you chose
  • Other settings made during setup that were not the default choices

btw, do you use proxmox ve for ucs?

I used UVMM (i.e. kvm) and VirtualBox in my tests.

Does proxmox have some kind of template or any logic to interfere with the VM? Are any guest-tools installed?

Not yet confirmed, but

Problem only occurs if you install Docker Containers after Kopano installation

We tried may constellations.
UCS Support is validating at the moment!

Cheers, the Noob

I came across another system the other day and traced this down to the Installation of a Docker App, too:

UCS 4.2-1 without Apps:

root@ucs-1613:~# md5sum /usr/share/zoneinfo/Europe/Berlin
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/Europe/Berlin
root@ucs-1613:~# md5sum /usr/share/zoneinfo/UTC
c79354b8dbee09e62bbc3fb544853283  /usr/share/zoneinfo/UTC

UCS 4.2-1 with Kopano-Core (Non-Docker App):

root@ucs-1613:~# md5sum /usr/share/zoneinfo/Europe/Berlin
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/Europe/Berlin
root@ucs-1613:~# md5sum /usr/share/zoneinfo/UTC
c79354b8dbee09e62bbc3fb544853283  /usr/share/zoneinfo/UTC

UCS 4.2-1 with Kopano-Core and ownCloud X (Docker App):

root@ucs-1613:~# md5sum /usr/share/zoneinfo/UTC
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/Europe/Berlin
root@ucs-1613:~# md5sum /usr/share/zoneinfo/Europe/Berlin
4790e83465681cefbf852aed265354bf  /usr/share/zoneinfo/UTC

As @onex pointed out, /usr/share/zoneinfo/Europe/Berlin is for some reason copied to /usr/share/zoneinfo/UTC. This happens somewhere during the Docker App installation:

root@ucs-1613:~# LANG=C stat /usr/share/zoneinfo/UTC
  File: '/usr/share/zoneinfo/UTC'
  Size: 2309            Blocks: 8          IO Block: 4096   regular file
Device: fd00h/64768d    Inode: 2358280     Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2017-08-01 14:33:11.144000000 +0200
Modify: 2017-04-04 17:01:29.147172000 +0200
Change: 2017-08-01 14:31:13.724000000 +0200
 Birth: -

This is from a test system where I started the OwnCloud installation around ~ 14:30 today.

1 Like

Yes, our support staff is working on that issue.

In Ubuntu based containers, /etc/localtime is a link, for example to /usr/share/zoneinfo/Etc/UTC. During the Docker installation, the App Center copies the file from the host into the container which overrides the file on the host. More details here:

1 Like

As mentionend in the comments on, the current workaround is to reinstall the tzdata package on the UCS host:

univention-install --reinstall tzdata

Edit: todays Errata 127 should prevent this error in the future.

1 Like