Can't install Benno Mailarchive

Hello all,

i’am using here UCS 4.4.6. I would like to install Benno Mailarchive on my Kopanoserver. But the installation always aborts with strange messages:

14797 utils                            20-10-09 00:09:05 [   DEBUG]: send_information: action=install app=benno-mailarchiv value={'code': 1, 'stderr': ['Joining', 'univention-join: joins a computer to an ucs domain', 'copyright (c) 2001-2019 Univention GmbH, Germany', '', 'Search DC Master: ', '', '**************************************
************************************', '* Join failed!                                                           *', '* Contact your system administrator                                      *', '**************************************************************************', '* Message:  Please visit https://help.univention.com/t/8842 for c
ommon problems during the join and how to fix them -- missing dns service record for _domaincontroller_master._tcp.osit.cc', '**************************************************************************', 'Something went wrong while joining the system']} status=416
14797 utils                            20-10-09 00:09:05 [   DEBUG]: tracking information: {'status': 416, 'uuid': '8081390e-c1c7-485a-910b-0d6df4131e39', 'app': u'benno-mailarchiv', 'value': {'code': 1, 'stderr': ['Joining', 'univention-join: joins a computer to an ucs domain', 'copyright (c) 2001-2019 Univention GmbH, Germany', '', 'S
earch DC Master: ', '', '**************************************************************************', '* Join failed!                                                           *', '* Contact your system administrator                                      *', '**************************************************************************', '*
Message:  Please visit https://help.univention.com/t/8842 for common problems during the join and how to fix them -- missing dns service record for _domaincontroller_master._tcp.osit.cc', '**************************************************************************', 'Something went wrong while joining the system']}, 'version': u'2.8.4', '
role': 'domaincontroller_slave', 'action': 'install', 'system-uuid': 'bc90d316-ab74-4bfa-ad5b-06b270ef3373'}

Why the system should able to join? This make no sence. Selftest is ok. So what should i do?

Benno no useable on UCS. Moved to Mailstore with WindowsServer 2019. Very bad, but the only solution.