Cannot upgrade Lets Encrypt from 1.2.2-8 to 1.2.2-16

System: 4.4-7 errata 877
Lets Encrypt:1.2.2-8

When I attempt to upgrade Let’s Encrypt to 1.2.2-16, I the upgrade process takes a little time with the message “Performing software tests on involved systems.” Then, after a few minutes, the system returns the error “Internal Server Error.”

image

I tried restarting the server before attempting the upgrade. The results are the same after the reboot.
I tried the upgrade on 3 other servers all with the same versions of software. The results are the same.

I have NOT tried uninstalling Let’s Encrypt and reinstalling since I was concerned that I would impact the web access to the system.

In the meantime, there are errors reported in the certificate.

Thoughts?

I had a similar error, but after running software update and getting all the packages updated and rebooting the upgrade ran fine the second time.

OK, I will look to do the same. Thank you!

I could not get LetsEncrypt to update via the UCS web interface.

Instead, I logged into the shell as root and

  1. ran univention-app update
  2. ran univention-app upgrade letsencrypt
  3. once complete, I exited the shell
  4. went back into the UCS interface, and, checked the Lets Encrypt app to confirm the upgrade.

As a side note, I had to perform this on a total of 4 servers. None of them would properly upgrade this app via the ‘standard’ software upgrade process through the UCS website.

Right now, all is up and running properly.

1 Like