Can not join Win 10 client to UCS server

Hello, I just installed UCS 4.4 in Digital Ocean droplet using manual.
After I added UCS IP as DNS in Win 10 client settings and tried to join client to qcerris.internal, I have this error:

DNS was successfully queried for the service location (SRV) resource record used to locate a domain controller for domain “qcerris.internal”:

The query was for the SRV record for _ldap._tcp.dc._msdcs.qcerris.internal

The following domain controllers were identified by the query:
ad.qcerris.internal

However no domain controllers could be contacted.

Common causes of this error include:

  • Host (A) or (AAAA) records that map the names of the domain controllers to their IP addresses are missing or contain incorrect addresses.

  • Domain controllers registered in DNS are not connected to the network or are not running.

nslookup is resolving both IP and domain, and:

_ldap._tcp.dc._msdcs.qcerris.internal SRV service location:
priority = 0
weight = 100
port = 389
svr hostname = ad.qcerris.internal
_msdcs.qcerris.internal nameserver = ad.qcerris.internal
ad.qcerris.internal internet address = 138.68.79.219
ad.qcerris.internal internet address = 10.114.0.3

Any suggestions?

Hey,

try add your UCS servers dns in windows 10 network and reboot your windows 10 and try again

Tried with UCS DNS IP set as client DNS, not working, but with different error now, not resolving anything with this setup. Looks like first variant is closer to solution.

Turns out that some clients, on random internet connection, win7 and win10, can join domain, but mine laptop, and few others I tried have error from first post. These failing clients use same ISP, if that matters. Any input on this? Nameservers are set up, no need to add UCS IP as DNS on client computer.

For sure you need to add the UCS server as DNS server for your clients going to be joined!

When joining the clients query the DNS for the DC hostname (and some more). Your provider usually does not have a clue about your internal network so any DNS query regarding DC will fail. And thus the join will fail.

/KNEBB

Latest update, looks like that Windows 10 build version is making problems. Windows build 1809 or later, won’t join, older versions can join domain. Anyone experienced similar issue?